Universal Mobile Ads for iOS & Android

I bought this plugin two days ago and it works awesome on iOS and Android both! Also awesome support! Big recommendation :smiley: :smiley: :smiley:

Are you planning on releasing any discount codes in the near future :p?

At this point I’m not planning any discounts in the near future :slight_smile:

Ah, I really wanted to buy this but I can’t afford spending $99 on it since I’m just getting started in the android game development. :frowning:

I think this plugin is worth its price because it’s a complex ads experience for mobile on UE4. As soon as you start earn money thanks to the plugin, your investment will return :wink:

I’m currently making plugin version for UE 4.11 Anyone has suggestions what can I add to the plugin or what to improve? Give me some feedback. Thanks :slight_smile:

Hello,

I’ve recently purchased your plugin. However, after adding its content to engine and project, I can’t start the project. Upon startup it says that plugin failed to load cause the module ‘UniversalMobileAds’ does not appear to be compatible with the current version of the engine. I am using built-from-source 4.10.2 with some custom tweaks to IAP functions. Does that mean that I need to somehow rebuild the plugin with my own engine version?

Update: ok I recompiled it, but now I get this error while packaging the Android project:

Hello Lordink,

Thanks for buying! :slight_smile:

Indeed, binaries are compiled for Launcher version so if you have UE4 from GitHub you should manually rebuild.

Error which you affected looks like bug in UE4 which users described on AnswerHub and forums:

  1. https://answers.unrealengine.com/questions/323850/missing-receipt-when-using-blank-template.html
  2. Source users must build UE4Game manually in Visual Studio for Android packaging - Mobile - Unreal Engine Forums
  3. https://answers.unrealengine.com/questions/289758/cant-package-missing-receipt-ue4game-win64-shippin.html
  4. Trouble Cooking Game (Program.Main: ERROR: AutomationTool terminated with exception:) - Platform & Builds - Unreal Engine Forums
  5. [4.8 promoted] Having some issues with deployment to IOS - Mobile - Unreal Engine Forums
  6. https://answers.unrealengine.com/questions/244239/build-failed-on-pc-of-ue-48.html
  7. https://answers.unrealengine.com/questions/178887/missing-game-binary-cant-pack-a-game-on-win64-ship.html

Please look at these links and tell me if it helps.

Thanks for the quick reply.

I was able to package the shipment version of the game, currently awaiting it’s update on Google Play alpha. In a meantime, the “Launch” to android device option still throws the same error I sent you previously. I was not able to find a workaround following the links you quoted, cause most of people there refer to 4.8 bug. What I did find out is that while the engine compiles, it fails the java build (or something). I think it is connected to the google play services that I pasted from your plugin to the engine folder. Here is the error:

I would note that I am using Nvidia AndroidWorks 1R2. Should I uninstall it and get a fresh CodeWorks 1R4 (I have not found a way to just update AndroidWorks), could that solve the issue?

UPDATE: I fixed the engine build error by deleting the old google play services from Intermediate engine folder. My bad. However, this did not fix the “Missing receipt” error while deploying.

UPUPDATE: Fixed! Turns out I needed to manually package the Development build, which did produce the xml receipt. Everything works fine now, thanks for the support. :slight_smile:

It’s awesome that it’s working now for you. Great! :smiley: If you have any more problems, please write to me :slight_smile:

http://gamednastudio.com/plugins/images/UniversalMobileAds/Update4.jpg

Now every buyer receives access to the private plugin repository on GitHub!

** You can now track code changes and download binary releases for different Unreal Engine 4 versions (now for 4.10 and 4.11)**

If you want to access to the repo, you can buy plugin on Sellfy: https://sellfy.com/p/V0sJ/

Finally I bought your plugin, so I meet some problems.
after I installed the plug in to my engine when I packege to android error pops out.
The error says ‘you don’t have UE4GAMES binaries’
How can i fix this problem?

Hello flower011red,
which engine version do you have and which operating system do you use?

okay.
I use 4.10.1 and win8.1

Binaries are compiled for 4.10.2

updated

I updated version, 4.10.2 has same error .

they say no binaries , how can i fix this??

I haven’t acted anything, cuz this issue.

Hi,
I’m planning to buy this plugin, but I have a question beforehand:
Do I have to register to all of the ad networks I want to use, and get to know them, or is it enough to register to MoPub?

By the way I got an email from apple recently, in which they said that they will discontinue their iAD service. Just saying, so people know, it wasn’t that easy to figure that out, as I had to send them a support ticket relevant to iAds, to know this. I wonder why Apple, or Epic don’t tell this to their users more explicitly, as this is critical information to some people who planned with and developed free games for a source of income.

  1. Are you properly installed AndroidWorks (CodeWorks)?
  2. This error occurs during editor loading or only during packaging project for Android? If yes, could you attach full build logs?
  3. The simplest way is convert your Blueprint-only project to source code project and then compile it. Another option is also create new source code project, compile plugin specific for your PC and then copy binaries to your Blueprint-only project :slight_smile:

Let me know what you decided and if it helps.

You should register only these ad networks which you want to use in your game. Only 1 ad network is required to display ads in your game but you can use all of them to maximize revenue. Each ad network you need to link to your MoPub account. It is necessary because of payouts and bank transfers. MoPub sends ad requests to multiple networks to ensure you find the best available network to serve ads in specific moment.

I’ll update plugin as soon as MoPub release new SDK version specific to iAd issue. It will probably be replaced by iAd Workbench. I’m also currently working on more new ad networks available in this plugin.

Hi,
I bought this plugin to use rewarded Video of Unityads and banner of Admob for android.
Admob is well run but Unityads is not work.
I entered into the text boxes of the Custom Event Class information as follows:
Android Rewarded Video | com.mopub.mobileads.UnityRewardedVideo | {“gameId”:"<104xxx>", “zoneId”:"<rewardedVideoZone>"}
Here I have one question. Why do I should enter “gameId”:"<game ID for iOS>" for android?
Anyway I got error code by using ‘RewardedVideoLoadFailur’ of this plugin.
Error code is ‘MOPUB_NO_FILL’ and ad requests count of statistics in UnityAds is 0.
How can I fix this problem?

Please, understand my poor English.