Unexpectedly quit after add a Content/Paks folder in Android

Hi,

I am doing the patch function for my game, by reference to this article. I made a patch pak file and download it into my android phone at run-time. But when I close the game and start it up again. It shows Failed to open descriptor file ‘…/…/…/TestPakWin2/TestPakWin2.uproject’ at launch time. I found the reason that cause the error is the folder Paks under the Content folder (ex:UE4Game/TestPakWin2/TestPakWin2/Content/Paks). Even if I create a empty project for Android, add a empty Paks folder under UE4Game/ProjectName/ProjectName/Content, it still cause the error. And if I remove the empty Paks folder under Content, the game works normally. In the article says the pak file can be mount automatically under the directories in FPakPlatformFile::GetPakFolders. But how I encounter the error like that? Is it a bug?

PS: If I put the patch pak file under /Saved/Paks/ folder, it works fine.

WingedRobin,

When I went through these steps on my machine, I actually ran into an issue where my project wouldn’t package at all. UE-35200 has been entered for this issue, which relates back to the ‘store all content in a single file (Unreal Pak)’ options is causing the failure.

  • Are you running into descriptor file issues when you’re not patching?
  • What kind of device are you on?
  • Do you have a sample project that you’ve replicated this issue in?

Please follow these instructions to obtain the logs from the mobile device, maybe it’ll tell more about the descriptor file.

  • Attach your phone to the computer
  • Go here: C:\NVPACK\android-sdk-windows\tools
  • Open up Monitor.bat
  • Launch the program and save the logs

If you cannot get Monitor.bat to open, please go to:

  • C:\NVPACK\android-sdk-windows\tools\lib\monitor-x86
  • Open up Monitor.exe
  • Follow the instructions above

Make sure that you highlight all of the logs, because they do not save unless they’re highlighted.

Thank you!

Hi Samantha,

Are you running into descriptor file issues when you’re not patching?

No, the app works fine. But even if I made an empty folder Content/Paks(without any file) under the project folder, the app still crush.

What kind of device are you on?

Samsung S2, RedMii Note, SONY Xperia Z3, the issue occurs on all these phones.

Do you have a sample project that you’ve replicated this issue in?

Yes, I create a FirstPerson template project and deployment to Android, the unexpectedly quit issue was also occurred.

By the way, it seems like if I pack my game into Shipping version, the descriptor file issue message will show up. But if pack into DebugGame version, it will unexpectedly quit right away without any message.

Log file of FirstPerson template project:

  • DebugGame version: here
  • Shipping version: here

Thanks :slight_smile:

Your logs state that your device is having a signal 11 crash. This is happens when memory is corrupt. It normally falls back on the devices GPU or the GPU drivers.

Try your projects on devices with the same OS, and on the same type of devices but with a more upgraded version of the OS and see if that helps.

Depending on how resource intensive your project is, it may simply be too much for those devices. Or what you’re doing may be too much for those devices.

I went ahead and pushed the FPS template to our Galaxy S2 from 4.13.0 and did not run into signal 11. The S2 that I tested is on 4.0.4 OS.

Thank you!

Hi,

Unfortunately, we don’t have so many device in same type but different Android version. My Galaxy S2 is on Android version 6.0.1 (Sony Z3 is on version 5.1.1, RedMii Note is on version 4.4.4), higher than yours. And all of these phones got the same issue even in FPS template project, so maybe OS version and intensive of resources are not the problem?

My engine version is 4.12.5, maybe I can try it on 4.13 later.

Thanks :slight_smile:

By the way, why my another post had been closed? I think there are in different issues.

WingedRobin,

I pushed the FPS template to our Nexus 5 which is on 6.0.1 and also to our Lenovo S939 which is on OS 4.4.2. The project did not crash on either device. These were the closest devices I could find to your Red MiiNote and your Sony Z3.

I opened your other question back up, I thought that you had updated it with the information from this one, my apologies. :slight_smile:

Samantha

Hi Samantha,

We use engine on version 4.13 and retry this issue again in this morning, but it still crush on RedMii Note when we add empty folder Content/Paks under the project folder. Would you please tell more detail about how you test this issue or did you change any settings? Thanks.

WingedRobin,

I did not change any settings. I created a blueprint FPS project in 4.13. I packaged the project and launched it onto the device, I also launched on from the engine onto the device. Neither time did the game crash on the device.

It could very well be the type of device you’re testing on but unfortunately, we do not have a Red MiiNote to test on.

Please provide me the monitor.bat logs from the Red MiiNote device only experiencing this crash in 4.13.

Thank you!

Hi Samantha,

So you package the project and add empty Content/Paks folder under UE4Game/ProjectName/ProjectName/ path did not cause the crash? Hmmm… that’s weird. My test project is in c++ version, but I don’t think that is the problem is. Anyway, here are the log file of RedMii Note and Sony Z3 build on 4.12, 4.13 in separately.

By the way, is your UE4Game folder under the root or under Android/data/PackageName/files/?

WingedRobin,

Looking over the logs provided, your devices are throwing out a Signal 11 error. Signal 11 error is a segmentation fault, meaning the program accessed a memory location that wasn’t assigned to it causing trouble. You can typically resolve this issue by upgrading the phone to a newer version of Android but sometimes it’s due to software or faulty hardware.

I launched a C++ FPS 4.13 project onto my Nexus 5 and did not run into a Signal 11 crash.

Thanks!

Hi Samantha,

Unfortunately, this issue are also occur on my colleague’s Nexus 5 and Nexus 6P(both on v6.0.1). Below are the crash logs:

Is your UE4Game folder under /storage/sdcard0/ or /storage/sdcard0/Android/data/package/files ?

Mine is listed under /Storage/Emulated/0/UE4Game and it works perfectly fine. Could you send your project to me through a private message on the forums to test on my Nexus 5? It could be something going on in your project specifically.

Make sure you include your exact packaging steps so I can see if it’s either your package or something set up in your project.

Thanks!

Here is the file of my test project, but I don’t think there will be any helpful info. Because I just create a C++ FPS template project and package it to android. It still crash when i add /Content/Paks/ folder under UE4Game/ProjectName/ProjectName/ path.

I packaged your project in UE 4.13 and had no trouble. I tried on my Nexus 5 which is on Android Version 6.0.1. I used packaging for Android All and ETC2. Was there a specific way you packaged your Android build?

Hi Samantha,

I use the batch file named cook_shipping_Android_release_CrashTest.bat that in zip file of my test project.

The .bat file that’s in the folder you provided me doesn’t have any apk or obb file along with it so I can’t even get it to install on the device.

Hi Samantha,

I mean I use that .bat file to package the android build and you can find the apk and obb file under Binaries\Android folder. Maybe you have to change both the path of RunUAT.bat and project inside the .bat file to run it successfully.

The packaged project you gave me does not work - there isn’t a binaries/android folder. I packaged your project myself though and ran it on a Nexus 5 and did not run into any complications. I have upgraded to 4.13.1 but 4.13.0 worked last week too.

I mean the way that I package the project is to use the .bat file. Then there will generate the apk and obb file under new created Binaries\Android folder. I did not compress the Binaries\Android folder into the zip file because there will cause the size of zip file more larger. So you should modify the path in .bat file and use it to package the project.

Sorry, I never edit the .bat file when I work on this - I either use Unreal Frontend, use the file > package option or I’ll use a command line (which is basically the same thing) but for some reason I didn’t grasp what you were saying. Haha.

Anyway, I managed to install on the Nexus 5 and ran into no complications. I went ahead and went back into the project and packaged it like you had it set up in the .bat file just to see if that would make a difference and it still ran for me.

Have you tested with 4.13.1 yet? Have you tried to package using the other various methods and see if you are able to get the package to work successfully for you?

Thanks!