Download

Unable to start Unreal, stuck at 39%

Well i got this stuck too, but i found a solution …
i installed “Process Hacker” it’s a task manager alternative software …after opening it - right click ShaderCompileWorker.exe and change its priority to High then right click again and select priority> Check “Save for ShaderCompileWorker” (u must do this step fast before ShaderCompileWorker.exe Restarts, it’s automatically restarts every few seconds).
and repeat those steps to UE4Editor.exe and BuildSystem.exe and XGEControlerWorker.exe.

for me after those steps ue4 took about 30 mins to open. Good Luck

Same here. I had to go to config file in project folder, open the “DefaultEngine” file with a notepad, and deleted the “Clearcoat enable=true” saved, and then it opens again very fast.

I modified the item like this r.PostProcessing.PropagateAlpha=0 in DefaultEngine.ini of config folder,the project can run now!

1 Like

I started Epic launcher with RUN AS ADMINISTRATOR and it finally opened on 4.25.1 BUT I am having issues opening projects from older versions. Errors out.

This.

This was the first solution that I tried and fortunately the last.

Short.
Try renaming the “DefaultEngine” file in the “Config” folder of your project, for example to “.DefaultEngine”.

 Expanded. Google Translate from russian:

Hi, I started learning Unreal Engine from one book and one of the lessons needed to download the “ContentExamples” project from the Epic store. I had the same 39% freeze problem. When, according to one of the tips, I changed the name of the “Config” folder in the project folder, my project began to run, but I could not control the camera while playing the level. Then I returned the previous name of the “Config” folder and renamed only the “DefaultEngine” file to “.DefaultEngine” in “Config” folder and it worked. Most likely, some setting in this file breaks the loading of the project, but everything works for me and more is not needed yet.

I did not find the settings in my “DefaultEngine” file that Daluz and yhy_fb wrote about earlier.
Launching UE from the administrator also did not help.

When I started out I had the same problem. I takes a really long time because of raytracing. If you disable Raytracing then it takes less time. Don’t mess with the process and just wait.

got the same issue stuck at initializing 39%

Same issue, but disabling ray tracing fixed it.

Can’t open nothing!

I just installed UE4 in 3 diferent computers all of them gives the error i believe that is an UE4 error with raytrace,the 3 computers are 2 laptos gtx 1050 and gtx 1070 and a desktop rtx 2070, when i try the 4.23 version it runs but when i get in rendering and activate raytrace UE4 ask for relaunch and gets stuck, in 4.24 dosent run, again the 39% error and in 4.25 i choose film and gets the 39% error but if i choose the spaceship game template UE runs so i guess the spaceship template dosent hace raytrace activated, im worried that ther are 3 versions that have this bug we are trying to migrate from unity to UE but this is a big problem, maybe any one in epic games have a final solution?

Checked the logs too, and the shaders are counting down here too. Looks like the devs just forgot about providing user feedback to let them know the app hasn’t crashed. It’s a common mistaked in software development. A simple “Compiling shader 123/4567” message would go a long way, rather than just having a percentage counter that seems to get stuck in a loop.

I had this issue with 4.25.3, I installed an older version of Unreal with the latest version and the everything started working. Wondering if somethings missing from the installation package.

do the same for Unreal Editor, and it will workhttps://www.youtube.com/watch?v=OyJS3je08z4

solution: grab every project that is stuck and remove its DerivedDataCache - Saved - config folder .
:slight_smile:

You should try to rename the Config folder in the project to Config_old, it works for mine.

Hi,

Same problem here. Just sits at 39%. No raytracing, scalable, no starter content. If I open an earlier version, it creates in less than a minute. So I tried creating it in an older version and then opening it in 4.25.3 - stuck at 39%.

So I had to go to defaultengine.ini and just rename it to “.defaultengine.ini” and bam, it opened right up.

1 Like

Happened to me after changing some configurations. I changed them back in PROJECT_FOLDER\Intermediate\Config\CoalescedSourceConfigs. For me it was in Engine.ini under [/Script/Engine.RendererSettings].

That works like a charme, thank you!

which defaultengine.ini should be renamed? when i search for it i get dozens of them… in which folder it is?