Unable to patch action graph - unexpected executable in compile action

Accepted Live coding shortcut

---------- Creating patch ----------

Running C:\Program Files\Epic Games\UE_5.0EA\Engine\Binaries\DotNET\UnrealBuildTool\UnrealBuildTool.exe -Target="VillageSimulatorEditor Win64 Development -Project=""C:/Unreal/VillageSimulator 5.0/VillageSimulator.uproject""" -LiveCoding -LiveCodingModules="C:/Program Files/Epic Games/UE_5.0EA/Engine/Intermediate/LiveCodingModules.txt" -LiveCodingManifest="C:/Program Files/Epic Games/UE_5.0EA/Engine/Intermediate/LiveCoding.json" -WaitMutex -LiveCodingLimit=100
  Win64 using Manual SDK 10.0.19041.0
  ERROR: Unable to patch action graph - unexpected executable in compile action (C:\Program Files (x86)\Windows Kits\10\bin\10.0.19041.0\x64\rc.exe)
Build failed.

I was reinstall IDE and VS2019. It still has a problem. Is there any way to fix this problem?

6 Likes

I have been getting this error as well, let me know if you find a fix.

i was getting the same error too a few min ago, managed to fix it by closing the engine and building the code from visual studio. then opened the engine and the code would build just fine from there too

4 Likes

Same here.
On UE5.0.0 (not EA)

ERROR: Unable to patch action graph - unexpected executable in compile action (C:\Program Files (x86)\Windows Kits\10\bin\10.0.19041.0\x64\rc.exe)

[Edit 1]
I’m getting the same error in UE 5.0.0 release. (Not Early Access or Preview)
PS: Using Jetbrains Rider IDE and have Rider Link plugin installed in the game.

[Edit 2]
I got it working by Running the engine from my IDE.
Got the idea after reading another post in forum. Someone got it working after using “Quick Restart” button which can be enabled if you disable instancing form Settings.
Link to post for Troubleshooting Live Coding.

5 Likes

Can you please explain how to run the engine from within the IDE? I am having the EXACT same problem as you had and it’s driving me crazy!

EDIT: Nevermind. I figured it out. You just click the “Run” button in the top right corner of Rider. I just didn’t see it. It’s actually working now! Thank you! :slight_smile:

@Schytheron Altough you figured it out but i’ll write it any way for anyone else who might be stuck.

For Rider, RUN (in toolbar) > RUN.

For Visual Studio,
DEBUG(in toolbar) > START DEBUGGING or DEBUG(in toolbar) > START WITHOUT DEBUGGING

1 Like

Hello!

Unfortunately, I have exactly the same problem with UE5.0.0 (final version).

First, I had the
ERROR: Unhandled exception: Dependency file “…GameModeBase.cpp.json” version (“1.2”) is not supported version error with Visual Studio 2022, then I downgraded to VS 2019, deleted the Intermediate folder, regenerated the solution with rightclicking the uproject file, then I had this ERROR: Unable to patch action graph - unexpected executable in compile action (C:\Program Files (x86)\Windows Kits\10\bin\10.0.19041.0\x64\rc.exe)

but only in the Live Coding screen when I start the build process from UE5.

When I start the build in VS2019, it’s successful. I am following Alexandra Kropova’s Unreal Master C++ Class tutorial, I am an experienced C++ programmer, but so far I wasn’t able to make my project running.

Take care, Miklos

I had this problem when moving my project files from one folder to another.
I don’t know if that was what you did, but if it was here it is what worked for me:

First thing I did: I had to search in every project file that had the old directory pointing to and change it to the new directory.
You can search for it in VS Code using the Edit > Replace in files.
image
Example:
image

Second thing I did was to run again the build directly from the VS Code in:
Terminal → Run Build Task
Also, I had to choose the “Editor Win64 Development Build” option to work.
image

After that, I reopened the UE Editor and everything was working just fine, including the Live Code.

1 Like

Had this same error message earlier.
Ran Build for the project within Visual Studio 2022 (Ctrl+B) and error no longer showed up!

didn’t help for me. Also tried build → clean option - didn’t help
Refresh Visual Studio Project Files not helping either

to be honest I am not sure what fixed it for me but I also did the restart which still showed the error. Then I closed the UE editor had the solution build from within rider and then launched the editor from rider. I don’t know why it bogged it in the first place but rebuilding and then starting from rider seemed to have done the trick.

I was stuck with this issue for a day and tried every method possible on the net, turns out I had to click on ‘ProjectEditor Win64 Development Build’ instead of ‘Project Win64 Development Build’ :'DDDDD

1 Like

The way I fixed this was:

  1. Shutdown Unreal Engine

  2. Shutdown Visual Studio Code

  3. Delete the following folders in your project directory:
    Binaries
    DerivedDataCache
    Intermediate

  4. Start up Unreal Engine with the project.

  5. It will give you a message about needing to recompile binaries etc (this will take a long time and the computer will appear to be doing nothing).

  6. Eventually the project will open in Unreal Engine

  7. Build it.

After this process I was a back in action.

14 Likes

Thank you. This totally worked for me :hugs::+1:

1 Like

Thank you for your way, I have fixed it!

1 Like

Thanks, it works.

If you are using rider with riderlink plugin installed and live-coding being enable, you will have to click the “Run/Debug” button, the triangle one or the bug in rider to run unreal editor.

Then you can use live-coding or debug c++ code in rider. It’s a little bit complicated though.

1 Like

just regenerate your project files. It can happen while changing project that have different unreal engine paths.

THANK YOU!

It has been discouraging to my progress with this error, and this is a quick & easy fix!

1 Like

Thank you soooooo much!!!
Had this problem for a week!

1 Like