Ugly and dirty looking shadows whenever I build my scene

I really can’t figure out why my shadows look like this whenever I rebuild my scene

I googled for hours and pretty much tried any solutions I came across, I have a lightmass volume and my lightmap resolution is 1028 which I suppose is plenty for a room.
is the problem caused by my lightmap UV? this is what it looks like.

and here’s my lightmass settings:

Any help is appreciated, thanks in advance!


Uncheck “Compress Lightmaps”!!
…also I would have my walls separate… with separate lightmaps! :wink: Would give a better result! :wink:

Hope it will help! :wink: