UE5 virtual shadow overflow

I feel like the only man on earth with this problem. as i can’t find a similar problem anywhere on google. The only major change i made to my project recently is enabling an apple media plugin. This has never happened before. please help


I am also having this issue, but no resolution as of yet.

I get same issue, and I barely started building my level. Unreal 5.0.3

I’ve the same issues too in ue 5.1

Same issue with 5.1.
It seems to relate to my scalibility settings. Whenever I lowered the scalibility group settings in the .ini file to below 3, the warning will show up. But if I manually change scalibility back to 3, the warning won’t show up. It also happens on certain computers it seems, some of my PCs don’t show this warning.
If anyone find a solution please let us know.

Have any you guys found any solution to this in the past few month? lol

There’s 5.3 preview which promises improvements on Lumen and hence maybe virtual shadows, but i haven’t tested it out with the offending project yet and maybe i wont.

I actually found a solution to mine, by going to DefaultEngine.ini and add r.Shadow.Virtual.MaxPhysicalPages=8192 manually, also I added a same command line in my level’s beginplay event to solve the problems.
Now the warning is gone.

that will increase the usage of vram afaik. so you dont see the error, but your gpu might run out of ram and decrease perf for other tasks. or it might not run properly on older gpus.

if im wrong lmk because that might help me too.

I’ve been struggling with this for quite some time on both 5.1 and 5.2. I searched every forum I could find and I swear I read the Virtual Shadow Map documentation page a half dozen times. I even tried setting r.Shadow.Virtual.MaxPhysicalPages=16384. Any higher than that would crash the edtior. So this week, I moved my project to 5.3 and “Voila!” the problem is gone.

btw another thing to keep in mind when changing r variables, is that some will get changed by the quality settings, either if you run benchmark or allow the user to change the presets.

But I think they won’t change if you have set a manual value (different than -1, which remains default), right?

well given my tests if you change the game settings then it will automatically set some variables.
i havent tested every single variable but seems a risk i vaguely remember it setting something about virtual shadow maps but cant remember what var.

i’d recommend you that at least you test that case.