UE5 Sequencer not rendering the correct Camera/Shot

Hello Im having issues with my UE 5 sequencer - I have a camera cut track with the binding correct and the image shows you what the camera sees and the send image shows what the camera is rendering

When I go to render out my shot - the camera immediately defaults to under the map to a random place for whatever reason = anyone have any leads this is really starting to drive nuts

2 Likes

Hello!

This is a very common mistake when another camera is in scene. Search for any another camera in the map and delete it. That should fix the issue.

Also, in the blueprint of the stage you can use a “Set View Target” node after “Begin play” to set what camera you’ll want to render by default.

I hope this helps you!

2 Likes

Also, just check in MRQ on the right side that you have selected the correct map and correct sequence. Make sure the cut track is the correct camera and also make sure no other sequences are set to autoplay

2 Likes

No this is not a two camera issue this is a bug. I’ve looked everywhere in my scene for a rogue camera and there isn’t one. I set up everything the way it’s supposed to be and it always has some weird view under my scene. This needs to be looked into and fixed instead of being swept under the rug.

2 Likes

I agree I also found a work around - you make the camera spawnable

2 Likes

Hey not sure if this will help you, but I ran into this bug earlier on in 5.1 and this solved it.

Go into the sequence you want to render out.
Go to the camera cut track and delete it.
Add a new camera cut track to the sequence and select your camera.

Voila it SHOULD render out from the camera you want.

3 Likes

This was frustrating to figure out. You Rock!

making commercial render now in ue 5.1 and it not worked for me :frowning:

For me enabling Async evaluation in the sequencer playback options fixed this issue

1 Like

try to make the camera spawnable, that worked for me

1 Like

Can we get a step-by-step on how to make the camera spawnable? or a link to a good tut video? :pray:

Total newbie here and I’m having the same issue. Very annoying indeed.

1 Like

Just right click on the camera in the sequencer, should have a “Convert to spawnable” at the top.

5 Likes

You cant possibly imagine how much time i invested in resolving this.
This was the answer for me.

THANK YOU.

2 Likes

glad you got it – it was frustrating for me lmao

u save my time. i try so much solutions but nothing work, ty

1 Like

You have saved me hours of frustration with this simple fix! Thank you!

Is there another fix for this? None of these are working for me? UE5 is currently up to date.

1 Like

Hey couple things:

The camera that you want to render is it in the camera track? and also you made the camera spawnable?

take a screenshot of your sequencer timeline real quick so we can see?

I had a similar problem where the rendered video would show angles from cameras that weren’t used in my sequence. Now, I’m new to UE so this could easily be something I did wrong but incase this helps anyone this was my issue and the solution:

I used the pre-built Polar Sci-Fi Facility from Marketplace. I stripped out the lighting and re-lit the environment myself, created a new sequence, added a little character animation and multiple cameras that I created. When I played the the sequence in sequencer it works fine but after I rendered it out new camera angles and a fade appeared in the exported video.

I tried all the tips people suggested here but none of them worked for my situation. The solution in the end was deleting all the cameras that were already in-place in the Polar Sci-Fi Facility (even though none were used in my sequence) and I deleted the already in place Level Sequence ‘Polar_Facility_Sequence_Daytime’.

Question - was the Camera Track Camera selected with all cameras switched to spawnable?