Download

UE5 - Nanite not wanting to work

Hey, So I have been trying to get nanite to work but for some reason everytime when I import a Nanite asset from Bridge I get the message on my screen “Nanite is used in the scene but not supported by your graphics hardware and/or driver. Meshes requiring Nanite will not render”, despite me having a GTX 960 and I have read that Nanite works from Maxwell cards and up

Any ideas how to get this fixed?

3 Likes

Same problem here, but this is an RTX 2080 card, latest drivers…

I can actually get it to work on Valley, but not on our companies project… We have several people on the same card, and this is the only machine that can’t render them, the only obvious indicator that something is amyss comes from the D3D log where it’s complaining about not supporting 64bit atomics

LogD3D11RHI:    0. 'NVIDIA GeForce RTX 2080' (Feature Level 11_1)
LogD3D11RHI:       8010/0/32742 MB DedicatedVideo/DedicatedSystem/SharedSystem, Outputs:2, VendorId:0x10de
LogD3D11RHI:    1. 'Microsoft Basic Render Driver' (Feature Level 11_1)
LogD3D11RHI:       0/0/32742 MB DedicatedVideo/DedicatedSystem/SharedSystem, Outputs:0, VendorId:0x1414
LogD3D11RHI: Chosen D3D11 Adapter: 0
LogD3D11RHI: Creating new Direct3DDevice
LogD3D11RHI:     GPU DeviceId: 0x1e87 (for the marketing name, search the web for "GPU Device Id")
LogWindows: EnumDisplayDevices:
LogWindows:    0. 'NVIDIA GeForce RTX 2080' (P:1 D:1)
LogWindows:    1. 'NVIDIA GeForce RTX 2080' (P:0 D:1)
LogWindows:    2. 'NVIDIA GeForce RTX 2080' (P:0 D:0)
LogWindows:    3. 'NVIDIA GeForce RTX 2080' (P:0 D:0)
LogWindows: DebugString: FoundDriverCount:4 
LogD3D11RHI:     Adapter Name: NVIDIA GeForce RTX 2080
LogD3D11RHI:   Driver Version: 466.47 (internal:27.21.14.6647, unified:466.47)
LogD3D11RHI:      Driver Date: 5-13-2021
LogRHI: Texture pool is 5607 MB (70% of 8010 MB)
LogD3D11RHI: Warning: Failed to query support for 64 bit atomics
LogD3D11RHI: RHI does not have support for 64 bit atomics

We forced a working machine to throw the atomics error, and it shutoff nanite as well.

You can get around the error a little bit by adding this to your defaultengine.ini under render settings

r.Nanite.RequireAtomic64Support=False

It at least allows you to have nanite objects in your scene… doesn’t fix the problem though

I have also an old gtx 960 and it works. However I have tried onto someone else pc with a 3060 Ti and Unreal crashes systematicaaly on import, we have tried different drivers but no luck.

So we’ve tracked down our issue, turns out that it was RenderDoc screwing up the check on 64bit Atomics, by disabling that plugin everything works as expected in our project. May be a rogue plugin on your side as well @Grot13

Thanks for the input :wink:
Unfortunately there was no plugin installed (only those by default).
It finally worked, but I gave up on this

I have Same problem on intel hd 2500