UE5 Crashes when rendering with MRQ

Hey all,
Could someone shed a light on my issue?
Everytime I try to render out a sequence with the Movie Render Queue, my program crashes out. This is the report:

LoginId:60aa892541fb1b3c720cb6a871a5e70f
EpicAccountId:9080afcb7c4a44a7b20270285e83d811

Assertion failed: ScatterBufferSize >= ScatterBytes [File:D:\build++UE5\Sync\Engine\Source\Runtime\RenderCore\Private\UnifiedBuffer.cpp] [Line: 622]

UnrealEditor_RenderCore
UnrealEditor_RenderCore
UnrealEditor_Renderer
UnrealEditor_Renderer
UnrealEditor_Renderer
UnrealEditor_RenderCore
UnrealEditor_RenderCore
UnrealEditor_Renderer
UnrealEditor_Renderer
UnrealEditor_Renderer
UnrealEditor_Renderer
UnrealEditor_Core
UnrealEditor_Core
UnrealEditor_Core
UnrealEditor_RenderCore
UnrealEditor_RenderCore
UnrealEditor_Core
UnrealEditor_Core
kernel32
ntdll


My current PC specs:
Ryzen 7 1700x
2x 1070ti
32GB Ram
SSD Core Drive

Is there something I’m missing? It works when I render it out with the Sequencer. Previous versions of UE5 were fine. Thanks in advance!

2 Likes

I am facing the same issue. Can you please let me know if you found a fix for this issue.

1 Like

Yes, I’m facing the same Issue while rendering. Please Help.
Thank You.

Got the same issue today when rendering. Checked the source seems like it’s related to the scatter buffer but I’m not able to further debug.

I guess there could be an argument to control the size. Now my project is blocked by this. Is there any idea about any alternative solution to get it rendered?

I finally used the “Movie Scene Capture (legacy)” to create the movie. Hope MRQ can work in the future.

1 Like

Short answer:
Disable Flush Grass Streaming and Flush Streaming Managers in Movie Render Queue → Game Overrides

Long answer:
I was having this issue rendering an outdoor environment that used the grass system for procedurally generating trees and grass.
ScatterBufferSize was the 1st clue…
I first disabled the grass entirely in my scene since it is “scattered”, then the render worked.
So at least the source of the problem was targeted.
Then, I was able to poke around Movie Render Queue to find a setting that controls the grass streaming.

Movie Render Queue → (+) Setting Dropdown → Game Overrides → Rendering Rollout:
Untick Flush Grass Streaming
Untick Flush Streaming Managers

This will cause the grass system to stream instead of create them all at once in a buffer…so you may need to adjust your animation to give all of your grass instances time to load.

Btw, this doesn’t have to be grass, it could be any instanced foliage / meshes that are spawned using the grass system.

7 Likes

Thank you! That has solved the rendering crash for me.

This was the solution, side note if any of yall are using the Brushify packs it utilizes the same grass function for its landscape. Onc e disabled it rendered for me aswell.

you solved my problem,thank you @jeffmeyer3d

Thank you for helping us

Ok this worked for me as well, almost (it allows me to render now) However, it looks like the land Heightmap resolution is not correct and therefore the scattered grass and objects are not quite right. I have a car driving through a scene. I wonder if I could create a foliage spawning radius around the car that is so big but not my massive level big that I could not see it in camera for the most part? Any Ideas I am rendering with realbiomes product and its not working.

works, thanks so much!