ue4 lens flare????

For you, I saw these two scenes in the official demo, the lens is very nice, but I didn’t find the unreal 4 cases, post processing volume do not out the separate effect, who knows how to do this in the unreal 4 in lens flare.

22bbd76a3d4e691f24f248a82a9cd0921617406f.jpeg

d0859764bbef6fa2465712d2a980bf89c14d799a.jpeg

I don’t think there’s a post processing way to get anamorphic flares by default.

You can probably do it with crappy fake particle sprites, but I would definitely rather see a way to post process it from brightness.

Hi Mango,

This effect was not achieved by using the lens flare in the post process.

This effect was essentially “cheated” by creating a particle effect with an emissive unlit material.

As you can see with these attached images (granted mine aren’t final or all that good. Just quickly thrown together for reference)

In this first image you’ll see the particle working in the scene.

particle in scene.JPG

Next is the particle system and viewing it in Cascade

ecf89b5d953ea1f11dca678cef81329e905a77d7.jpeg

And this is basically all you need for the texture.

b75a9bfcd7d8f94903ed8b4dd965fb6f65437b4f.jpeg

When setting up the particle system there are a lot of features in here to tweak to get a good look. The basic look I have here I used the defaults and only got rid of the velocity to not have the lens flare move. There are some other things to change as well to get it perfect!

Have fun with it and if you have any questions let me know!

Tim

Hello, I love this function, thank you to my reference, but I do after I set in accordance with the dazzling shine, there will be several layers. You can send me you create this effect and materials of the.Uasset file.

Hello, I love this function, thank you to my reference, but I do after I set in accordance with the dazzling shine, there will be several layers. You can send me you create this effect and materials of the.Uasset file.

That last image was not intended to be downloaded and used. that was just a screen shot from within the editor of the material. that’s why there is a white line at the bottom and top on your image.

You’ll need to find an image that you can create this effect from or make your own. You will want to make sure that it is capable of being masked so that you do not have the black area shown like in your image. Although I would argue that what you’ve created does look like a wicked portal, especially if you were to add some other effects around the edges!

bab0f19ad26a27b1892efcb1d8041a45c6b54a22.jpegI made a special effects editor, but he will not stable fixed there, amplification is flickering, but not reach the style UE4 in the demo demo, I very like this engine, at the same time I am also a lens flare fan, I sincerely hope that the official can give me a about creating lens flare in the special editor help

Does the official, will join lens flare specialized in Unreal Editor 4 me?

This is useful info thanks Tim. Is there a good basic tutorial for the particle/sprite editor you could link me to?

Hi Tim, Is it possible to share P_WeldSparks Particle System, Is it possible to share P_WeldSparks Particle System - FX - Unreal Engine Forums

Unfortunately, I cannot share any assets like this from content that has not been publicly released.

The basic setup above should be enough to get your started with the anamorphic lens flare though.

Hello Tim, Thanks for the fastest respond. Actually I used Particle System of “1.4 GPU particles with Point Gravity“ (P_GPU_particles_attraction.uasset) from Effects Content Examples, which is closed to my idea how to achieve Anamorphic Lens Flare. You can see my video here

Here is the example project from Eric Ketchum, Is it possible to share P_WeldSparks Particle System - FX - Unreal Engine Forums
And here are two pictures of my Anamorphic Lens Flare:


Nice!

Eric showed me the start of the project he posted yesterday when he was working on it. He is our VFX guy and can do some fun stuff with Cascade! :slight_smile:

I’m glad you’ve got the results you’re wanting.

Judging by the last photo it seems you have the same issue I’ve been running into, intersecting nearby objects. Is there no solution for this at all?

You should be able to go into the material used for the lens flare and tell the transparency render to skip depth checks (or something similar in name). This causes the material to always render on top.

I use it for spawning certain effects (text bubbles that say “THWAK!” and “BLAM!” and such) to avoid intersection. I’m no expert on the science of lens flares but I don’t think there’s a situation where they OUGHT to be occluded by nearer geometry so that should work

I disabled the depth test, but then it starts to render even behind walls.

Well yeah, it will do that… But I’m assuming, and correct me if I’m wrong here, that a lens flare should be a conditional thing to start with. i.e. it shouldn’t EVER be omnipresent, it should only appear when the player is a certain distance and angle relative to lighting for a particular object, fading into and out of existence.

Again, no lens flare expert, but it seems pretty strange to me to be designing a lens flare that’s just always there. I would have assumed you were already doing some sort of math and traces to figure out when to spawn the particle effect and control its size such that it wouldn’t appear unless the point of flare was visible to the player already…

No, that isn’t supposed to happen. The wall should occlude the lensflare if you are viewing it from the back, the side where the actor isn’t placed. Here’s a clearer demonstration of the issue - Anamorphic Lens flares in UE4 [Pics] - Rendering - Unreal Engine Forums

Hi SE_JonF, I used this tutorial to remove harsh edges in intersection between objects: Wiki Visual Effects: Lesson 02: Using Depth Fade, https://wiki.unrealengine.com/Visual_Effects:_Lesson_02:_Using_Depth_Fade
Here are two pictures without and with Depth Fade Material Expression Node:


38dffe80c11430666766ea8aa0c9e76cd44f0e6a.jpeg

Hey Angel, while it isn’t as bad as a sharp intersection the lensflare shouldn’t be intersecting with nearby objects at all which is what I’m trying to avoid. I do this by checking the box “disable depth test” in the material, but that then presents the issue where it isn’t fully occluded when the actor is behind a wall.