UE4 Freezes when ran with -DX12 arg on laptop running 2080 MaxQ without secondary screen

UE4 Freezes when ran with -DX12 arg on laptop running 2080 MaxQ without secondary screen. It works fine when I launch it on a secondary screen as primary/sole screen.

  • I’m running a RTX 2080 Max-Q Design on the Razer 15, with the 418.91 drivers.
  • with Win10 1809
  • I select the laptop screen as primary/sole screen (secondary unplugged)
  • I fire UE4editor.exe with the -dx12 arg
  • launching a blank new project on which I have enabled both the enabled Support Compute Skin Cache and Raytracing in the project settings

Then the editor freezes after a few seconds. No crash, no crash window, but totally frozen. The rest of the machine is fine. the editor freeze seems to happen faster when opening the raytracing dropdown menu. It systematically freezes once Pathtracing kicks in or when I fire a raytracing Cvar.

But when I run it on a secondary screen as primary / sole screen, everything seems to be in order.

  • I have tried a clean re-install of both the Nvidia drivers and UE4.22 p2
  • I have also tried to reset all settings to default in the Nvidia control panel’s 3D settings.
  • I’m not using any fancy software or anti-virus (new system)
  • The GPU activity monitor shows that UE4editor.exe is running with the 2080 Max Q GPU (even when ran with laptopscreen as primary/sole screen)

any ideas or advice?



We’ve recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.



Thanks Jeff, I’ve reported the bug: Case # 00099889

Same issue on my Aero15x 2070maxq GPU, I have to use secondary screen to run raytracing, did you fix that?

Exact same issue with me on a laptop with 2070. I couldnt fix it completely, and epic unfortunately couldnt reproduce it, but when I download editor symbols for debugging, and also add -d3ddebug as an extra argument besides -dx12, it runs without problems on some projects, but some larger projects crash anyway. I first thought the issue was related to ray tracing but I dont have any problems with Ray Traced games or My own built ray traced projects, i also dont have any problems without dx12 enabled. I just hope they could reproduce the situation, since it doesnt crash I also cant send crash reports, it would be cool if you also submit a bug report so maybe they can reproduce it with you, I dont think its a difficult to solve problem.

It could be perfect if all of you guys submit it, so maybe they could reproduce with you guys, I had unfortunately no luck.

Same here, including the release version of 4.22.

Laptop is a Razer Blade 15, with an RTX 2070 MaxQ.

It also happens when using a thunderbolt dock (Razer Core X) with a Quadro RTX6000 installed, and connected to a 4K monitor.

just sent a report with the above information

I’m having the same issue with a 2080 version of the Razer Blade

have you sbmitted a bug report

I’ve just submitted one now, yes

cool, hope they can reproduce it.

yep that’d be great. Thanks guys.
I’ve installed NVidia’s Creative Drivers, hoping that they might help forcing the card to prevent the lousy integrated graphics to interfere. they didn’t.

I did the exact same thing hoping the same result, unfortunately, it was the same result on my end too.

btw you can also try to enable the d3ddebug to see if it helps, it works on my pc but some large projects crash.

'm having the same issue with a 2060 rtx MSI GS65

looks like a lot of people have the same issue on laptops, I wonder if theres even someone who doesnt have any issues on any laptop with an rtx card. did you report it btw?

Same issue on MSI GS65 (2070-MaxQ).

I can even make it freeze in the project explorer, just by right clicking a project a couple of times :S

Running on secondary screen seems to work though - pretty weird bug.

4.21.2 also seems to work fine.

exact same situation, try enabling editor symbols for debuging, even though some large projects crash, you can at least run some smaller projects on your main monitor.

There are new Nvidia Drivers that looked like they might have solved it for a moment, but sadly it doesn’t look like they have :frowning: