UE4 freezes my PC when building lighting

Screen shaking sounds strange. Is the same thing happening even if you build lights for a small level like the startup map with chairs and table? Is your CPU fan working properly(and check the temperature if you can when you start building the lights)? Are all of those parts brand new?

Hello I have Unreal Installed on 2 PC’s in my house. I just built a new PC built specifically for making games in UE4. Whenever I start I hit the build button with in the editor it begins fine then freezes at 0% then locks up my PC and the screen starts to shake. The only way to fix this is to turn off the PC by holding the power button down. What can i do to fix this like I said brand new PC with all brand new parts.

PC Specs:
AMD Phenom xII @3.4Ghz,
Nvidia GTX 680 2GB,
Gigabyte 970A-D3P Motherboard,
8GB DDR3 Ram,
2TB Western Digital Hard Drive,
750W Power Supply.

yes everything is brand new and the cpu temp is at 32-42 degrees with all the current drivers

Hmm. How about the gfx…which driver do you currently have installed? And can you post your dxdiag report please? I dont think i’ll be able to help you further but those may help Epic staff investigate the issue easier. I moved your post to Bug Report section, btw.

the current graphic driver is 340.52. here is the dxdiag

I now got it to load to 100% but it gets stuck on starting up swarm connection and the system still freezes

Hi Panda,

I’m currently using a similar setup for my work machine but I do not get things like this going on.

You said you have two computers that have UE4 installed. Is your other one giving you any sort of issues?

Also, when you try to build lighting which project/template are you using? Are you using a unmodified template and getting this issue?

Thank you!


I don’t have this problem on my other pc at all. I’m using the First person template

still having problems. Can someone help please?

any ideas?

installed the new nvidia drivers that came out 2 days ago and still having the same issue.

You seem to have a system that is up to spec. I’m not exactly sure why this is happening and it’s not something I can reproduce on my end. Can you try uninstalling the engine and reinstalling to see if this helps?

Yes i did try re-installing it 2 days ago and also tried the GetHub version. It still freezes and locks up my pc at 100% when trying to start connection to the swarm client. The new nvidia drivers removed the screen shake that i was getting but my system will still lock up and i have force my pc to restart by pressing the power button to be able to use it again.

Is there another way to receive tech support, because I would really like this to be taken care of so I can get back to our project. We have already been set back 2 weeks now by this problem and really cant afford to be waiting anymore.

The only other suggestions I have for you at the moment would be to try would be to delete the SwarmCache folder located in C: \ users \ [Computer name] \ AppData \ Local \ Unrealengine \ [Engine Version] \ Saved \ Swarm \

Delete the Swarm Cache folder.

If this doesn’t work try increasing your Virtual memory in windows. 8gb’s of RAM will go quickly and this may be the reason the computer is freezing. If that’s the case I would suggest upgrading your amount of RAM.

Let me know how this goes.


I tried to delete the Swarm Cache folder and tried installed another 8gb’s of ram from my other system making it a total of 16gb but both did not work. The system still freezes.

I know this is frustrating but here is something else we can try. I won’t mislead you on this, but I’m running out of possible things to try aside from re-installing windows to see if that helps. I don’t want to necessarily suggest that though.

Ok, try to disable any anti-virus & firewalls (including windows default). Try deleting the Swarm Agent cache data again then restarting the build process. And try running the editor as Administrator.

Thank you for your patience and willingness to work on this.


I have tried but it still freezes my system. I also did some testing to see if it was the video card or CPU using 3D Mark and got a 11302. So I don’t believe that it ether of them or any hardware everything is temping out correctly with correct voltages. So i’m guessing the next step is to do a full system re-install?

It’s a possibility this may resolve the issue, but I cannot guarantee it. This has resolved one case in the past that I’m aware of, but so has the other solutions I’ve recommended as well.

So I just re installed windows 8.1 and it working now. From what I’m guessing the windows install had a problem with the swarm client and it seamed to get stuck in a loop, could be the cause of my PC freezing up. But everything is working fine now thanks for the help. Is there anyway to get some credit for the whole month of not being able to use the engine?