UE4 don't use the right UVmap

Hi everyone !

I have a serious problem and i fail to fix it : I export an asset (3d object) who have 2UV map (UV1 for texturing, and UV2 for lightmap baking) i make on 3dsmax, to UE4.
It’s a FBX, and UE4 use my uv2 (lightmap) instead of the UV1 (texture).
I check on the UE4 object settings, and the both UV have the same thing on it (UV2 map is on UV channel 0 and UV channel 1)

Who can i fix this problem ?

I already try some other way, but no one works…
I try to use OBJ format, it work but, i’m working on professionnal project and OBJ are diseable…

Thanks for your answer ! o/

Hi Sally_bouth,

If you have the Lightmap UV you can manually set this in the Static Mesh Editor under the Settings tab on the right. You just need to look for Lightmap Coordinate Index which should be on 1 (UV Channel 1 in UE4, but UV Channel 2 in your modeling program).

If you want to use the UV Channel 1 (UV Channel 0 in UE4) as your lightmap UV as well, you can do this by unchecking the option for “Generate Lightmap UVs” or just setting the Lightmap Coordinate Index to 0 in the Static Mesh Editor.

If you’re still having issues or it’s causing issues please post a screen shot of your settings and the issue it’s causing with your asset itself.

Thank you!