UE4 crashes in OR Direct mode

I’ve been trying numerous ways, but no matter what I do, UE4.5 or 4.6 crashes in Direct mode. It crashes on any UE4 .exe (either mine or from the Oculus share), and it crashes when I open the UE4 editor:

Access violation - code c0000005 (first/second chance not available)

OVRDisplay64 + 25145 bytes
OVRDisplayRT64 + 41621 bytes
OVRDisplayRT64 + 22780 bytes
UE4Editor_D3D11RHI + 199098 bytes
UE4Editor_D3D11RHI + 373160 bytes
UE4Editor_RHI + 215660 bytes
UE4Editor_SlateRHIRenderer + 273389 bytes
UE4Editor_SlateCore + 872516 bytes
UE4Editor_Engine + 3527355 bytes
UE4Editor_MoviePlayer + 78096 bytes
UE4Editor!FEngineLoop::PreInit() + 10461 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.6\engine\source\runtime\launch\private\launchengineloop.cpp:1342]
UE4Editor!GuardedMain() + 236 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.6\engine\source\runtime\launch\private\launch.cpp:110]
UE4Editor!GuardedMainWrapper() + 26 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.6\engine\source\runtime\launch\private\windows\launchwindows.cpp:126]
UE4Editor!WinMain() + 249 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.6\engine\source\runtime\launch\private\windows\launchwindows.cpp:202]
UE4Editor!__tmainCRTStartup() + 329 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]

I have a DK2 and am using an Asus Repulic of Gamers laptop with an GeForce 880m, 24gigs and an i7 and am using Windows 8.1 with the latest GeForce drivers.

It works in extended mode but am looking for the performance gains from direct mode.


Hey -

There are a couple of questions I have that will help identify what the problem is. What Oculus runtime are you on? Does the crash occur if the Oculus is off when you open the editor? Are you able to open the editor with the Oculus in Extended mode and then switch to Direct? Let us know if there is any additional information you think of that may relate.


Hey ,

I’m on the latest runtime (0.4.4?) If the device is off, and I have direct mode enabled, it doesn’t crash. If I then turn it on and build, it crashes. I have not tried opening in extended and then switch, will try it but suspect it’ll crash.

Now, I got 4.7 preview 3 and when I just do the FPS template in direct mode, it works. I did discover that, but obviously that doesn’t help with my massive project that I’m bringing in from previous versions. I then went back and turned-off all of my console commands from the blueprint, but that didn’t help.

I must have been mistaken. I tried 4.7 preview 3 FPS template again in direct mode and it crashes on loading the editor. Additionally, I tried using extended mode, then switching to direct once inside the editor (UE 4.6) as you suggested, and it crashes the same. Any ideas as to what’s going on?

I’m having difficulty reproducing the crash on my machine. I have the Ouculs connected via Direct mode and can launch the editor and open a project without any crash. Are you launching the binary version of the editor from the Launcher or are you using a source version? Does the crash happen when launching the editor (trying to get to the project selection screen) or when opening a project? Having the log files from the crash will also help shed light on the cause. This wiki page gives the default file path for where the log files are saved: A new, community-hosted Unreal Engine Wiki - Announcements - Epic Developer Community Forums

For the time being I would double check the runtime (0.4.4) and the Firmware (2.12) and possible try updating them both to be sure.

Thanks . I am launching the binary version from the launcher. The crash occurs two ways in direct mode: 1) If I have the OR on and try to open the editor and 2) If I have the OR off, open the editor, turn it on and then build and run the project.

I can confirm that I am on 0.4.4 and firmware 2.12. Attached are the log files from the latest crash.link text

Thanks so much for looking into this. I certainly can’t be the only machine with this issue.

Hey -

I am having difficulty reproducing the crash you’re having when launching the editor. I have reported this issue to our internal tracking database (UE-8305) for further investigation by our engineers.


A few questions:

Have your tried uninstalling the Oculus runtime entirely and reinstalling it?
Are there any other potential oddities with your Oculus runtime install? Switching between versions, etc?
The configuration utility demo scene works fine in direct mode?
Do you have any startup movies specified? If so, can you test again with them removed?

Mine also crashes using Direct Mode. I think it is due to having a laptop with a dual graphics card setup; an Nvidia Geforce GTX860M and Intel Integrated Graphics. The HDMI port that the Oculus DK2 is plugged into is on the Intel Integrated card.

When I run Unreal with the Integrated Graphics card selected, it doesn’t crash but has an unusably slow frame rate.
This appears to happen for other games and not just Unreal so maybe an Oculus runtime issue?
Running in extended mode, with the Nvidia Geforce selected, the Oculus works fine; I can tell the Nvidia card is definitely doing the processing (even though the HDMI port is on the Intel card) as the frame rates are much higher.

Hey Kernel14-

This crash is still being investigated and has been resubmitted with updated information as UE-9316. Thank you for the information about the dual graphics cards, I will include be sure to include this info as well.


i’m also having this crash with my laptop that has dual graphics (msi gs60)
it has integrated intel 4600 as well as nvidia 870m

oculus drivers 0.4.3 and 0.4.4 have the crash.

both the editor and our game crashes. it works fine on our desktops.
on my laptop, if i force the game to run on the integrated 4600, it doesn’t crash

Hey -

Do you still experience the crash if you use 4.7.1? I would also check that the laptop has the latest drivers for the NVidia. If you are still having issues please include the log file from the crash as well.

Hi ,

Just an update on my last post to let you know that Oculus Rift DK2 in Direct HMD mode is still crashing on UE4 Engine 4.7.2. I am using the latest Nvidia drivers 347.52. It crashes when attempting to launch the engine from the Epic Launcher (Details below).

As mentioned I think it’s because of the Integrated Intel / Nvidia GTX860M GPU combination, with the Oculus plugged into the HDMI port on the Intel card. I haven’t had much luck using Direct HMD mode on any Unreal or Unity games but have had success with Grid Autosport and the Oculus Demo Scene which work fine in Direct mode.

Error details from launching Unreal:

Access violation - code c0000005 (first/second chance not available)

OVRDisplay64 + 25145 bytes
OVRDisplayRT64 + 41621 bytes
OVRDisplayRT64 + 22780 bytes
UE4Editor_D3D11RHI!FD3D11Viewport::FD3D11Viewport() + 721 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\windows\d3d11rhi\private\windows\windowsd3d11viewport.cpp:61]
UE4Editor_D3D11RHI!FD3D11DynamicRHI::RHICreateViewport() + 168 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\windows\d3d11rhi\private\d3d11viewport.cpp:461]
UE4Editor_RHI!RHICreateViewport() + 140 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\rhi\public\rhimethods.h:1463]
UE4Editor_SlateRHIRenderer!FSlateRHIRenderer::CreateViewport() + 477 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\slaterhirenderer\private\slaterhirenderer.cpp:266]
UE4Editor_SlateCore!SWindow::ShowWindow() + 215 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\slatecore\private\widgets\swindow.cpp:1087]
UE4Editor_MainFrame!FMainFrameHandler::ShowMainFrameWindow() + 266 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\editor\mainframe\private\frame\mainframehandler.h:205]
UE4Editor_MainFrame!FMainFrameModule::CreateDefaultMainFrame() + 4199 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\editor\mainframe\private\mainframemodule.cpp:202]
UE4Editor_UnrealEd!EditorInit() + 3591 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\editor\unrealed\private\unrealed.cpp:115]
UE4Editor!GuardedMain() + 926 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\launch\private\launch.cpp:133]
UE4Editor!GuardedMainWrapper() + 26 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\launch\private\windows\launchwindows.cpp:126]
UE4Editor!WinMain() + 249 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\launch\private\windows\launchwindows.cpp:202]
UE4Editor!__tmainCRTStartup() + 329 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]

Hey Kernel14-

We are still investigating the exact cause of this crash and the best solution. You are correct that it seems to be related to the integrated graphics card. As an extra piece of information, let us know what brand of laptop you’re using.

Thanks , I’m using a Lenovo Y50-70 UHD (non-touch). Let me know if I can help with anything.


I’m also experiencing this issue on a new Alienware 17. The oculus Config Util and demos work fine but no UE4 projects run when the oculus is plugged in. The computer has a NVIDIA GeForce GTX 980M Graphics card.

hey , sorry i haven’t gotten back to you.

our project is currently running 4.5 and won’t merge to 4.7 until next month. i’ll download the launcher 4.7.2 version and try with a test project.

Experiencing the same issue on Asus ROG laptop …i7-nvidia 860m


I am also having this issue on 4.7.3 with windows 8.1 on my new Alienware 17.

If I run the engine on the integrated graphics card only (Intel HD 4600) it does not crash, when I run it on the dedicated graphics card (NVidia 970M) it crashes.

It works fine with all other programs (oculus config utility etc) It also works on fine on my desktop.

Could it be a similar issue to a previous one I came across?

Hey Dominic666 (and everyone)

We are still investigating why there is a crash with one card over the other, however based on the information provided it appears to be related to using the NVidia card for most users. For the time being I would suggest using the integrated card instead or running in Extended Mode rather than Direct. We will post additional information here when we have a better idea of what is causing the crash.