UE4.8 Multiplayer Shootout Project MainMenu Don't show

After convert to version 4.8 , Multiplayer Shootout MainMenu Widget only load first time.

Hi Jason77,

Thanks for report! I’ll be looking into what might have caused that, but you should know that 4.8.0 version of project has been made available and can be downloaded from Learn tab now. Let us know if you have same difficulty with latest version.

In meantime, I haven’t been able to reproduce this in 4.8. When you say that Main Menu widget only shows up once, can you be more specific? Do you mean across multiple play sessions? Any further details could prove helpful. Thanks!

Thanks , i was already download 4.8 version and tested. problem was still exist, it did not show menu widget again when second time reopen mainmenu map.

By way you may try open mainmenu map, continue with play game, continue with open ingamemenu, continue with leave game. Then you will go back to main menu map without widget.

Hi Jason,

Thanks for additional details! I’ve been able to reproduce this behavior in 4.8.0 as well as our main build, so I’ve entered a bug report (UE-17175). It seems there’s some differences in how widgets are unloaded in 4.8 when moving between maps, but I haven’t been able to find specific cause in this project. I will let you know if we can find a workaround until sample is adjusted. Thanks for your report!

Issue still reproduces.
Steps to reproduce:

  1. Launch game as standalone from editor
  2. Press Play
  3. Press Escape key and choose Leave

Instead of menu you see black screen if you close window UE4 crash reporter window appears
saying “You do not have any debugging symbols required to display callstack for this crash.”

My system is win 8.1, engine version 4.8.2-2614606+++depot+UE4-Releases+4.8

Thanks! Yes, this still occurs in 4.8 version of this sample project and sample will probably not be adjusted until 4.9 official release. I will post here when I know more.

we are at 4.9.1 and this issue still exists…

Is there is still no fix and also no workaround for this?

No update on bug yet, but this can certainly be fixed. Keep in mind that it’s only a sample project. It just needs to be updated to match changes in UMG that occurred between 4.7 and 4.8. If I can find time, I’ll see what those changes might need to be and post them here.

is this even being looked at?

Ok, thanks, I’m using sample project as a base for my menu and I do not know how I would make it work in 4.8.

These are changes i made to make project work.

BeginPlayShowMainMenu: problem seems to be that when you are leaving level your current state is Playing and not Startup.

Then when you leave game and go to Main Menu mouse cursor doesn’t show.

It seems if you call ‘Set Input Mode Game Only’ then call ‘Set Input Mode UIOnly’ without mouse being captured in-between causes this behavior. Essentially this is what is happening by calling ‘Hide in Game Menu’ then calling ‘Show Main Menu Event’. This need fixing, i can see this as being a bit of a gotcha!

Replacing the ‘Hide in Game Menu’ with a ‘Remove from Parent’ in InGameMenu widget solves that issue.

I hope this helps someone.

Thanks, I also had to get rid of related State nodes in MyGameInstance EventGraph, then it worked.

Turns out it works in editor but when running it outside of it it opens menu in a loop when going back to it. I then tried setting it up differently, everything works fine in editor. But when running it outside editor in game menu opens but apart of that does nothing. I can see how buttons get visually clicked but anything it fires is ignored, even print on screen doesn’t show up.

It appears there are several things broken concerning menus. Is there any menu setup that works in 4.8 and higher and works when run outside of editor and works for multiplayer games? Are there any such example I could look at?

This is still happening in 4.10.4 (I’m also using it as a base for my own MP game), and Chooka’s workaround below doesn’t seem to work. There are also a bunch of compiler errors when you create a new Multiplayer Shootout project and open it, about not being able to connect some pins because of old classes and such.

Would be awesome if this example project could get an update, since it appears to be only real example of handling MP player-joining-a-server stuff in blueprints…

Hello Spoondog,

You are correct, after double checking on this issue for you it appears that it’s status has not yet been updated to fixed. However, I will be sure to bump up your community interest for this issue.

Make it a great day

If anyone is having this issue on 4.10.4 (i.e. where main menu doesn’t show on startup ONLY when you play packaged game), try this:

Go to Level Blueprint for Main Menu. Connect “Cast Failed” to same place successful cast from GameInstance to MyGameInstance connects. For some reason, this cast only fails in packaged builds, but it doesn’t really fail as you can still call the “BeginPlayShowMainMenu” event on it and it works fine.

Problem still appears in 4.11.2 to me.

I found a small and simple fix for problem, if you still have it.

First convert project, because it is still 4.10 although You select 4.11 while creating project, to 4.11.2.
(Convert Projects to higher engine version: Open blank Unreal Engine 4.11.2 . Then in Project Browser select Multiplayer Shootout and open it. In next window select more options and select open copy.)

After project is convertet, go to MyGameInstance, then to ShowMainMenu Event and then all way to end where add to viewport node is. In front of this node add a 0.1 seconds delay and main menu will appear.

This fix will NOT work in 4.10

Strange bug

Still not working in 4.13.1 … after getting the .1 delay once returned to main menu. It shows up but now Server List will not show up any longer ._.
Has anybody found a solution to this problem yet?

I’ve run into same issue. It pretty much happens with any game when you start it in multiplayer mode. Tested with 4.15 as well.