UE4 4.8 and GearVR issue

I’m trying to build to the GearVR from UE 4.8. I followed all of the instructions in the docs, and the application builds and runs. Yet, when I put the GearVR I just see some color patterns. See the attached image. Any ideas what is going wrong? I am using the first person template (when I tap the button on the side of the gear I can hear the shooting sound effect).


Turn off Mobile HDR in the rendering settings. It does all sorts of weird stuff like this. But I wish we could keep it on, because I think AA depends on it (?).

This is the same problem I’m getting. I have Mobile HDR off. If you take it off after seeing that, count to about 20, and put it back on, you’ll probably see your scene.

I posted here:

Mobile HDR is definitely off.

Thanks! After taking the Gear off for about 20 seconds and putting it back on I was able to see the scene. OS is KitKat.

Hey Ethereal,

I just wanted to let you know that I put in a Jira ticket for this as I ran into the exact same issues last week. Not sure when the VR team will get around to fixing it but it is now on their radar. Let us know if you find any more problems and I will see what I can do to help.



Thanks Sam!

Sure hope it is a top priority…can’t release anything in that state. Also, what’s the eta on getting the Samsung blue tooth controller working? This need to be a top priority as well.

Same here. Had to put some projects back on 4.7 !

Does anyone had chance to test it on LOLLIPOP to see if is definitively related to Kitkat?

I’ve tested on Lollipop and the issue does not appear. It means you can’t use the AA hack though. Either way projects are almost unreleasable.

I’m having a different isssue. Anyone seen something similar to this before?

Still not resolved on 4.8.1

Kitkat 4.4 bug, temporary "fix"

Actually, the only workaround is to put a finger on the Gear VR sensor for 2 second, remove the finger, wait 20 seconds, and then wear the Gear VR for testing.

4.8.2 released.

bug still there

4.8.3 was just released and the bug is still there.

(edit: I removed my snarky comment)

4.9.0 Preview 1 also has this bug.

4.7.6 does not have this bug so I downgraded my project to it. Even though this bug is reported to only occur on Kit Kat 4.4, that is the version of Android on the vanilla Samsung Note 4 that I bought from T-mobile for my GearVR.

4.9.0 Preview 3 does a quick flash of light blue vertical bars to the left and right, then black, then Oculus menu, so I assume that it crashed.

YAY! 4.9.0 Preview 4 fixes this. :cool: