UE4.3 Second "Client" Screen Black

So I was following along with the Networking blueprint tutorial and wanted to try it out my self. So I opened the blueprint 3d person template and set number of clients to 2. Just like in the tutorial video. When i hit play, the server window shows the level, but the second screen (client) goes black and nothing is generated. I have Qualcomm Atheros Killer Network card on my motherboard, which i found a possible solution regarding that, but still did not fix my problem.

My Rig:
i5-2570K O.C. 4.2GHz
Dual GTX660 SuperClock SLI
16GB Ram 2133 MHz

video of what I am doing… ErraOfWar UE4.3

1 Like

Hi ErraOfWar,

Which play mode are you using, Play-in-Editor? And does this happen in a new project as well?

Also, could you post your dxdiag?

Sorry I won’t be home for a while. I was using create new window, and default settings. I basically just started a new project and tried to copy the tutorial and it get client screen black. I don’t get any popup messages or anything.

I haven’t been able to reproduce your issue, two clients work fine for me in 4.3.1. This makes me think it could be hardware related. As soon as you have time, please post your dxdiag and we will take a look. Below is a link on how to find that info if you need it.

Thanks, TJ

i have recorded what i am trying to do and what happens. Along with running dxdiag.

Bump. Anyone have this same problem?

Hi ErraOfWar,

I’ve attempted to reproduce this on various machines but so far I haven’t been able to get your results. Have you downloaded the 4.3.1 hotfix and retest the issue yet?

Yes I have along with 4.2. I think i’ve narrowed it down to being a network issue, but I still can’t find out why. It should work with my network disconnected through local host and I can ping local host. So I have no idea why this won’t run the server and client windows.

Hi ErraOfWar,

Version 4.4.0 of the editor is out now. Does this issue still happen with this version?

I’ve looped in another developer and we are still unsure what the issue could be. If you find anyone else with a similar problem (AnswerHub or Forums) please post a link here.

Thanks, TJ

Yes I still have the same problem :/. My rig is more than capable to run this engine and has 3D rendering. I have even disconnected from the internet to run though localhost, and i can ping and ping localhost just fine. I have read some posts that people were having troubles with Killer Network card their motherboard which i have, but I also have a wireless card that i tried running just through that, and still have the same problem. Unless there is a collision happening right on level startup with 2 characters, causing the other one to not render, i have run out of ideas.

Hi there, sorry this is an issue you for.

Definitely not seeing this here.

Can you try to launch QAGame, and run a server (QAEntry?Listen -game), and connect with a client (run with the same cmdline as server, but then open console and type “open”) and see what happens?

Can you also post the logs from the server and client sessions?


Sorry due to this issue still relatively new. What is QAGame?

Hi ErraOfWar,

Sorry about that, QAGames isn’t available for you. Basically John just needs you to reproduce the issue in a new game with a template the we have access to as well. Something like the First Person or 3rd Person template.

If you look above I have posted a link to a video file of me recording my steps to get my problem along with my dxdiag. I will also try the command lines when I get home.

Well after some suggestion from friends i figured out what was going on. When my game started both the server and client were trying to spawn in the exact location and the server won and the client wouldn’t render. So i just simply had to move the server character out of the way and reload the map on the client. However, I still can’t see both characters at the same time on either screen, just the character that belongs to that screen.

It sounds like the characters network replication isn’t setup correctly. I know you were working through the Network Tutorial series. Did you complete the second video? It talks about how to set that up.

Sorry to be noob/pain just having so many issues with this multiplayer networking, give me visual basic and im set haha. Anyways… So just like the networking video i’m trying to produce my server character and client server on the same screen, so i can see each other running around. However, when i create a new project, set the clients to 2, and run in new editor windows like the video the server screen shows the character and the client screen is black due to what i assume is collision. But if i move my server character away from the spawn point and go to the black screen client and type “open MapName”, it will spawn my client to that map. The problem now is when i do this… i can’t see the client character on the server or the server character on the client.

Even though it appears that the light source following the character on the client affects the server character’s lighting, the character model it’s self does not show. (the replicates box is checked on my character)

Which new project template are you using?

Third person. Both styles and I’m pretty sure first person was doing it to me.