UE4.26 rivers causing crash

Hey all, so I’m trying to add rivers to my landscape, I’ve enabled all the plugins and everything, set my landscape to edit layers. I drag the river in and the shaders start compiling but then just before they finish the engine crashes, with a message above shaders saying “landscape edition waiting for edit layers resources to be ready”
I’ve followed as many tutorials as I can find but no idea what to do here anymore

Hi, i do have the same issue all the time. I have no clue how to avoid it.

hello, same thing for me … when I rotate / move / scale … unreal freez

hey i tried to lower the quality of the landscape and it worked just fine, no crash

I have had the same issue. And later when I did manage a spline with no crash, I saw no water body! This is what I eventually learned and have this resolved:

  1. UE4.26
  2. Enable “Landmass” plugin
  3. Make sure you have a small landscape, a very large (I initially had 4K that I reduced to 2017x2017) areas seem to crash.
  4. Make sure your entire landscape is above zero. Use a “target point” actor placed at 0,0,0 and check in a L or R view that the landscape is above.
  5. Check “Enable Edit Layers” option of Landscape.

Also see: Landscape Blueprint Brushes | Unreal Engine Documentation

This question is from 2020, around 6 months old. But hopefully this helps anyone who visits here.

1 Like

For anyone copying and pasting a landscape and get this error:

  1. Uncheck “Enable Edit Layers”
  2. Recheck it