UE Megascan Distance Shadows Disappearing?

Hey All, as you can see in the video, when I zoom out the shadows on my grass disappear. I tried changing values within my movable directional light and nothing happens. Has anyone experienced this issue while using megascan grass assets? If so, have you figured out how to increase the shadow render distance? Thanks

Do you use raytracing and displacement? Then try the command r.RayTracing.NormalBias 10.
Another idea is, try to disable all LODs of the mesh except LOD0.

I found the culprit. Even though I am not using raytracing in the post process volume, ray tracing is enabled in the project. So I had to add “r.RayTracing.Geometry.InstancedStaticMeshes.Culling=0” to my DefaultEngine.ini file. This solved my issue.

1 Like

Thank you! It was a real pain in my back for all Friday night.
Tried foliage lod, material settings, lights shadow distance, different similiar console command ( r.RayTracing.Geometry.InstancedStaticMeshes.Culling )