UE Build Lighting 0% - MacOS Solution - Dec 2022

Hello, Mac users! I found the definitive solution to Build lighting stuck at 0%. It is pretty simple but it took me two years to figure it out! It has everything to do with permissions to the UnrealLightmass file. It is located wherever your version of the engine is kept ie: ~/UE_5.1/Engine/Binaries/Mac/UnrealLightmass. I keep all my engine instances on an external thunderbolt drive.

Step 1: Make sure you do have the UnrealLightmass file added to your MacOS firewall under System Preferences/Security & Privacy/Firewall/Firewall Options. Click the (Add) + button and navigate to the UnrealLightmass file and Allow Incoming connections. If you haven’t done so already. Now OK and close your Preference panel.

Step 2: Simply double-check any other software you may have installed such as “Little Snitch” and they are not blocking any UE related tasks.

Step 3: Go to the “UnrealLightmass” file via your finder window and select it.

Step 4: The answer you have been waiting for… Right-click that file and Get Info. look at Sharing and Permissions and make sure every account you have listed there is set to Read & Write. I had my user account on Read & Write but the Staff and Everyone were on Read-only. I changed those two and the problem was solved!

Step 5: Go to your project and Build your lighting!

I really hope this helps, if anyone still has issues I will be happy to try and help you.
Good luck! :smiley:

I have to amend my post to say: The next day I seemed to go back to square one. After doing all this work, I couldn’t build the lighting! After further investigation and a few more tests, I found that I had to disable my MacOS firewall completely. I thought I could narrow it down by deleting all epic-related processes, but that didn’t do it. So as a test I proceeded to build the lighting for my project, and while that was happening I disabled the firewall. As soon as I did that, the build lighting started immediately. To recap, I would still complete the steps in my first post and disable the macOS firewall. You should be good to go. :sweat_smile:

This topic has been moved from International to Development: Rendering.

When posting, please review the categories to ensure your topic is posted in the most relevant space. Hopefully, this new category change will help others to get an answer.

Happy Developing! :slight_smile:

Hi PresumtivePanda, How are you? Thanks for moving this to a better spot. However, I am not looking for an answer. In this case, I am providing one. The question is very common among Mac users and I have been searching for a solution for a long time and I finally figured it out.
If you think there is a better spot for this please let me know. I am just getting used to using the forum.
Thanks for your moderation! Have a good day! :smiley:

Oh, sorry! My mistake :slight_smile: I’ll keep it in the rendering category as it’s where people with similar questions would look. Thanks for helping me to fix that!

1 Like