[UE BUG] Entire PC freezes and I have to Hard Reset it.

Hello, I’m using 4.17 and 4.18 no matter which scene is open it can freeze entire PC and nothing is happening, it just doesn’t move and never saving the file or any auto backup. Complete hard crash, not even Blue-Screen, I cannot track the problem due to inability to save anything.

I thought it’s Nvidia drivers, I have installed an old driver from September, 385 remove all Nvidia stuff, unfortunately, it did not help.Then I installed the most recent (388.13),
how to fix the problem? Is there any way to find the cause of the freeze?

Have you been able to use UE4 previously? What’s your computer specs?

Yes I was using it since version 4.9 everything was okay,
my set up is pretty usual, Win10, Nvidia 1080, SSD1TB, 64GbRAM (3000Mhz) and Intel i7-6700 4Ghz.
I still working, but I have 3-5 freezes day, then I hard resetingand working for another 1min-3hours and then Freez Hard resent and keep working. Scene can be complete new or empty, it happening only while I fly over the scene, FLY - is the problem probably.

Someone had the same issue? Is there any way to track it?

Report this on the answer hub.

I did reported there few times, no one has replied. I also noticed answer hub is useless for many questions, the chance to get the reply there is very low and msot of the time just a waste of time posting there.

It is still happening, I have 3-8 freezes a day, I quickly reset PC unpluging it from the power and plugin back, this is how I work now. Today it has freezed once I was saved the material. It can happen any time while I work in UE, but never happen anywhere outside UE4, so I assume this bug started to exist in the newer UE4.17.2 and UE.18.1 still there

I had similar issues on my older computer (Geforce 770) and found a bug while searching online. Apparently there are several Nvidia cards that have this issue and Epic is investigating. I lost about 10 hours of work before I decided to upgrade. Now I have a 1070 and no issues so far.

Suggestion: Try changing to an older Nvidia driver for your GPU and see if it makes a difference. In my case, going back a few months made things better.

CoquiGames Thanks for the advice! I will try to move to 6 month back driver.I still have few freezes a day; I noticed they are mostly while I calculate the shader either in the material editor or viewport it stuck when it’s starting to calculate it. I will report how is going next week.

What I did yesterday:

  1. Moved entire projects to HDD from SSD, did not help
  2. InstsalledNvidia Driver from June 2017 (now is November 2017) and it did not help
  3. Noticed it is only happening while it calculates the shaders, after a fresh restart, it still freezing if it starts to compute the shaders.

Decided to do the project on the other machine, currently looking for the computer to work.
Only happening in Unreal Engine 4 V.4.17.2 and newest, maybe I won’t be able to use my machine anymore for developing the projects if this bug will exist since now.

It sounds like you have a conflict of sorts. I re installed 4.17.2 last week on win 10 and linux mint everything is working. I had a ram leak that was due to a bad bp. It would continue crashing until i deleted the other bp’s that were trying to ref them. Maybe try a linux build it would at least tell u if your having issues with windows. Linux turns grey when compiling shaders. Just a warning. It can at least tell you if its something hardware related.

I will look for solutions, I currently lost entire project, something went corrupted and I cannot open the project anymore.

yesterday I damaged the project due to UE4 freezes my pc while doing some shader calculations. I lost entire light bake and for some reason all cinematics scenes has lost their content inside, they weren’t even connected between each other. Problem still exists, I don’t even know about full reinstall of Windows 10, becuase it seems like they did some bug and no update would help it.

Brand new Windows 10 on a brand new hard drive, did not work, I’m distraught, I think this is a glitch only of the unreal engine, not Windows nor Nvidia drivers.
Since I have tested it all, googling prior problems from other users telling me UE4 has to be fixed, Unfortunately, I 'm only the victim now of my laptop’s configuration, and I cannot work in UE anymore until they are going to fix a glitch which I cannot even track due to hard freezes. Thanks

It’s probably not UE4, otherwise there would be many more people having the same issue. I would run a Windows memory test and see if there might be something wrong with your RAM

I know it doesn’t make sense, but it is only happening inside Unreal Engine and just in version 4.18. I am going to do memtest for sure. Overall I’ve read many articles about common problems in Unreal Engine and freezing entire PC, not just crash but freezing and then hard reset.


Does this freeze your entire PC? Your clock won’t update and your mouse cursor won’t move? I have a similar issue but it is few and far between, usually happens if I leave UE4 open for >45 minutes to an hour. I’ve just been saving my work repeatedly and making sure to commit code changes in case it freezes. I’ve found that restarting UE4 every half hour or so to seem to avoid the problem, but obviously this is not a solution and sometimes building light can take that long.

This never happened when I was using anything below 4.18, skipped 4.16-4.17 so I’m not sure what’s going on. My PC specs are:

CPU: AMD FX-8350


GPU: GTX 970

EDIT: Are you doing your project in C++ or blueprint? I wonder if Visual Studio might have anything to do with it?

I have laptop Sky X9E2 (i7-6700, 1080Geforce, 64GB RAM, SSD) and Windows 10 PRO, my laptop just stops responding and freezes the screen for 30 sec and then changing colour to random (pink, yellow, red) and then just stays like this for hours until I hard reset it. It mostly happens when I work in the material editor, but sometimes after freezing I restart and run UE again, and it freezes in the first 15 sec, I don’t know why, I can’t even track anything, I restarted my PC yesterday with fresh hard drive, and today it occurred again. The only suspicious thing that left is a RAM. I have 64GB 3000Ghz speed on ram, it very fast in comparison to 2400 that was there by default. I changed my BIOS settings in summer. I had a couple of freezes there, but then I swap them in order and it was working fine. But this is maybe the problem. I had not tested it yet if it’s going to happen again I going to lower the speed to 2400 back as it was by manufacture when I got my laptop. It’s okay, but compare to 3000 for some reason I have noticed significant speed overall in the system, everything just flies. Did you touch any RAM or BIOS clocks?

Sure … or … maybe unreal engine is actually just a ‘symptom’ of another underlying cause. The fact that this isn’t a widespread reported issue (a point mentioned by others), means that probability-wise, you need to do more testing (fast assumptions aren’t helpful in solving this here). Could it be something you’ve overlooked… For starters, how well have you sanitized your rig? I saw many fly-through level crashes from 4.4 to 4.9. but hardly any from 4.10-4.18. Plus, none caused the machine to lock up, just UE4 to crash. Crashes are more likely too when a gaming rig is going flat out / heavily saturated (during UE4 project startup, shader compilation or level fly-thru’s when shader work is ongoing etc). So any updater / scheduled-task unhelpfully kicking in at that time, could be a smoking gun / tipping point…

Kudos! That kind of diagnostic info was missing from your other threads / posts. UE4 crashes are common, but total hardware lockup isn’t. You can’t blame unreal engine yet though, as its unlikely to be the cause. More likely the unreal crashes are a symptom of some other underlying cause… (Video-Driver / Video-Hardware / Motherboard / Memory).

Your description regarding the ‘freezing’ is familiar… I used to have those kinds of hardware lockups (Win7 Asus ROG Nvidia GTX-670m based laptops). Not Ram related (ran tests anyway). They were always video card driver (video card / motherboard hardware related). Driver updates didn’t bring a magic solution (updates were few). Sometimes dump files got created (*.dmp). They always pointed to video driver / hardware failure (windows debugging symbols required to read the dumps). Over time by keeping good notes and sanitizing the rigs, I could see the underlying crashes weren’t caused by UE4 or UDK or Unity or games etc. They could even occur just doing everyday tasks in Windows. So what helped? Cutting out all the bloat and unnecessary excess processes definitely helped with stability. But that’s not the same case for you though, or is it?

There was no fix (at the time I was regionally outside Asus’ laughable-worldwide-guarantee (only covers USA, Canada, Mexico). But by profiling the machine I noticed the situation was significantly improved by stripping the OS back to basics (locking down the rig). Killing every Service that’s non-essential. Disabling window updates (unplug from the net during tests). Properly disabling all Updaters: Google / Adobe etc (not just taskkill - kill them at source)… Disabling all Scheduled Tasks (often hidden / obscured by Microsoft / Google / Adobe etc). Scrutinizing Run / Runonce commands and DLLhost / com spawned processes etc. Basically eliminate all Crapware / Bloatware / Updaters (Sysinternals / Autoruns tools help). In short, test without interruptions and prevent anything else from running (including browsers with add-ons).

This is extra tricky seeing as you’re using Windows-10, as you don’t want to have to troubleshoot lockups against the backdrop of ‘a moving target’… That’s the real elephant in the room and the single biggest point of failure (updates overlapping tests etc). Plus, there are different builds of Win-10 and differences again by region, so how do you compare like for like? Either way definitely unplug from the net during tests…

Have you messed with the TDR settings in the registry? I’m pretty sure that can cause a hard-lock if they are incorrectly modified from the default settings. Look up TDR Manipulator and within that program, you should be able to reset things back to the Windows defaults.

If it’s doing that kind of weird screen color thing then that’s a GPU issue. Try and move your GPU to another slot if you can.