UE 5.1 Massive DX12 RHI Lag

Hi, I’ve needed to upgrade engine to 5.1 for fix seamless travel problem. But this time I get RHIT lag on empty scene. It reaching massive numbers every 1-2 seconds. What can I do? Has anyone encountered this problem?
I’ve tried to change RHI & Shader formats but it didn’t work.

My game is on Steam page which needs to be downloadable in a week. I need to discard game if I can’t find any solution of this. :frowning:


Looks like it fixed with 5.1 release.

I have the same problem, but in 5.1 , in 5.0.3 works fine, you “have luck” or you do something?

Maybe. 5 and 5.1 are so unstable, so I suggest you to avoid if you can. I’m getting new errors/warnings on 5.1. But I’ve just verified the engine on Launcher and removed DX12 version and SM6, it looks fixed.

I think that if you don’t active DX12 and SM6 Lumen and Nanite don’t work.

I’m having the same issue with the RHI and I didn’t find the solution yet.

The same project in 5.0.3 worked fine.

Anyone has some clue?

I found the solution to my problem with the DX12 RHIT massive lag.

In my case, the problem was the spotlights.

When I try to increase the Source Radius IN SPOTLIGHTS the RHIT goes off the charts. While I change this parameter on Pointlights or Directional Lights goes smooth.

But if I disable in the spotlight->light->advanced->Cast Ray traced Shadow the problem dissapears.

It only happens in the spotlights and I’ve got abled DX12 and SM6, and I using Nanite, Lumen, Virtual Shadow Maps and Raytrace with Lumen.

So right now I cannot use raytraced shadows in my projects :confused:


Interesting, I have lots of spotlights too. I’ll try with SM6, DX12, without spotlights.

I’ve enabled DX12, SM6, Virtual Shadow Maps, and lots of SpotLight but I don’t see any changes on RHIT.


I’m Having the same problem but mine is a bit different, the RHIT gets really high when i get near nanite meshes, this seems to happen with any mesh. I tried multiple projects and a clean install of the engine and the problem persists.


Getting the same thing with Nanite mesh. 13900k/3080ti/128gb of RAM. Should be fine, but my ms times are insanely bad on any scene with nanite.

1 Like

Exactly the same issue in 5.1.0. ray traced shadows hangs editor for 40sec, unusable now. Slowly adding back lights it works for a limited amount. Interestingly turning on transmission for the lights gives better performance.
I am stuck with this, would like to change the version due to alembic hair fix. The project is unusable in 5.1.0 with RT shadow on. Tried a bunch of voodoo and black magic, no solutions so far. For me the shadow batches are the slowest. Not sure what going on, but expected that between 5.0.3 and 5.1.0 there will be no breaks like this. Thanks for the info.

Have another, but related problem here and here, so it looks like SM6/VSM and Raytraced shadows are really broken in 5.1, what a shame. Hope it will be fixed soon

Just an update on this:

  • Enabling transmission on lights helps a bit with fps, instead of being slower.
  • The light casting the ray traced shadows cant be rotated more than 360. I mean, i dont know why someone put those values, but that instantly creates/adds to the hang.
    It feels like a close to memory max issue. 5.0.3 with the same setup except sm6 gives much better performance and no hangs. I can only have kind of the same speed with disabling hairstrands on the character.
  • continued voodoo and r. attribute tweaks did not help so far. Driver updates / migration redo and things like that also ends up hanging. If you dont have trdelay overridden it is always a freeze instead of message: payload did not finish in 40sec for D3d12RHI.
1 Like

I’m using 4090 and still get this issue with spotlights. 6 spotlights in the scene, but they are moving heads so they do have a rotation of more than 360. I turned on the transmission and it works great. Paradoxical stuff…

We’re having this exact same problem. Project worked fine in 5.0.3, in 5.1 fps dropped from 60 to 12 on 4090. Can be fixed by either setting source radius to 0 or raytaced shadows to disabled on spotlights. Using nanite and lumen, dx12 sm6.

Incredible work guys. RHIT usage spiked dramatically after a few minutes of running the project just fine. Disabling ray traced shadows on spotlights completely fixed my problem after hours of troubleshooting. It was driving me insane that I couldn’t find a solution until I came across this thread

Disabling CSM Caching in project settings temporarily lowers it for me, but the RHIT usage goes right back up after moving in the editor so i can’t really call it fixed…

can confirm. same issue with spotlights source radius and raytraced shadows. just converted a project from 5.0.3 to 5.1 and the frame rate dropped from 60ish to less than 1fps on a 3090. I’m just using one spotlight, all other light types work fine. Source Radius 0 on spotlights fixes performance issues as well…

I am still trying to find out. Check one thing: set the draw distance to the current attenuation value then change the attenuation to a higher number. Amazingly this solves the issue… WHAT! Also, it seems like for me the problem is instant if I have hairstrands. If light targets the hair it works fine. Once the light does not hit the hair it drops to like 0. Tried a bunch of cvars, no luck so far.