Download

UE 4.20p4 ARCore image database cannot build.

Hi, i try to create a simple image recognize app, but when packaging, i got this error:

“LogInit: Display: LogGoogleARCoreAPI: Error: Failed to build augmented image database.”

I was created image database.

My image database is a Data Asset -> GoogleARCoreAugmentedImageDatabase with only one image.

The AR Session is a Data Asset -> GoogleARCoreSessionConfig

ARCore plugin enabled, android config is ok.

What im missing?

There is anyone who can succesful build image database?

Not tried myself yet but does changing the Session Type to Image or Object Scanning make a difference??

I think the problem is the ARCoreAugmenteImageDatabase not the session. When try to packaga an empty project with only an ARCoreImage Database, get the error too. Somehow cannot build the image database, and look like missing arcoreimg.exe.

Still not work fit 4.20p5

What the different between the ARCandidateImage data asset and the GoogleARCoreAugmentedImageDatabase data asset?

The ARCandidateImage store the images, what i want to recognize, right? Thats work on ARCore and ARkit too?

This still does not work. Any update? Anyone gotten it to work? Even tried on the June 2018 release of 4.19 with AR Core 1.3 build directly from Google and it fails, same error.

SOLUTION!!! (EDIT)

I got it to work. So I tried to create the database manually using arcoreimg in cmd with the correct commands, and it throws an error that there isn’t enough feature points to track accurately.

Make your tracker image more complex, bam it worked 100%!

EDIT 2: I noticed the 4.20P5 build is missing the Tools section of the ARCore, so I tried to copy/paste them from 4.19-ARCore and it failed still.
So this does not work in 4.20P5, you must use the 4.19-ARCore source build from Google.

GitHub: https://github.com/google-ar-unreal/UnrealEngine/tree/4.19-arcore

Hello, can you explain this? What command used? Thanks

@Hermyth here is the commands: The arcoreimg tool  |  ARCore  |  Google Developers

I manually built an image database file. If your image doesn’t have enough feature points, it will throw an error saying so. If it does, it will work.
Mind I have edited my post above (including a link) that shows you must use a certain source build of Unreal 4.19 provided by Google, which has the arcoreimg tool and ARCore 1.3, opposed to Unreal’s 4.19 and 4.20P5 having no arcoreimgtool and ARCore 1.2. I also tried copying the tool to 4.20P5 and it doesn’t work.

I have learned in the 4.19-ARCore build from Google, you don’t need to use the commands to build a image database manually, but the build will fail if the images aren’t complex enough, and it won’t fail if they are. Hope this helps!

Hi, thanks for the fast answer. I tryed with that engine version too, with the image detection example, but get the same error. But now try build with command line. Thanks again.

Your tried with qr code? i hope can recognize that.

@Hermyth I just tried with normal images. If it doesn’t work, likely your images aren’t complex enough.
To double check go to:

Make a copy of CMD and put it in:
EnginePath\Engine\Plugins\Runtime\GoogleARCore\Tools\Windows

Then type: arcoreimg build-db --input_images_directory=/path/to/images --output_db_path=/path/to/myimages.imgdb

You will see if it works or fails due to complexity errors. If it works, than just build the game as normal

Ok, thanks.

I just copy the tool folder with arcoreimg.exe from the git version of ue4 to the ue4.20p5 and its work fine, not need cmd line. :slight_smile:

Interesting… I tried this and it kept failing…

And work with qr code too.

From the GitHub link that I sent? Very confusing to me. Lucky you, it does not work for me, but the same images work in 4.19-ARCore

Yes. downladed that 4,19 git version, unpacked, run the setup.bat, and when that done,copyed the tools folder to my 4.20p5 “UE_4.20p5\Engine\Plugins\Runtime\GoogleARCore” folder.
Packaged the project, and then launched on phone.

@Hermyth Are you using 4.20P5 binary from Launcher, or 4.20P5 source from GitHub?

Im using the simple launcher version.

Hey guys,

I also just ran into this problem. One thing I found is that ARCore seems to prefer square images. I had a rectangle image that would give me an arcoreimg score of 5. When I cropped it to a square, it gave me a score of 100. (Interestingly, the rectangle image is no issue for ARkit).

Unfortunately, after importing the square image, the build still failed with the “Failed to build augmented image database” error.

I wouldn’t mind trying the manual build process but where do the resulting files go?

Using 4.20 p5 and trying to create a project for both iOS and Android.

Thanks!
Serge

I’ve been trying to test out the Augmented Images sample with Google’s 4.19 build but whenever I load the app on my device, it crashes after I give it permission to use the camera.

I’m testing on a Samsung Galaxy S9+, has anyone else had issues with this device?