Download

Trying to achieve the same lighting as The Witness

I’ve been trying for a while to achieve the same lighting as in a game called The Witness. Unfortunately it seems to me like it’s impossible in Unreal Engine. The shadows in UE4 are just too dark and harsh and I can’t seem to make them any lighter without making everything else overexposed. Is anyone able to help me figure out the right settings to achieve this kind of lighting? Here are some examples:

The Witness:

Best I could do in unreal engine:

What I tried:

  • Increasing the skylight intensity (Causes everything else to be overexposed)
  • Using a cubemap (Makes everything more white but doesn’t help much)
  • Increased the number of indirect bounces
  • Played around with Lightmass

They’re also able to have a very nice transition between indoor and outdoor areas, something which is very hard in unreal engine.

Is this kind of lighting even possible in unreal engine?

Other things to try are tweaking the indirect lighting intensity and saturation on the directional light and skylight. Skylights don’t support bounce lighting, so some people use bounce cards near the windows that get hidden during play:

You can also try adding some reflection captures inside and increasing their intensity.

You might want to try manually setting exposure too, auto exposure is going to try and get a good balance between shadows and highlights by default and you are looking for really soft lighting with almost no blacks.

You can do a lot with color grading and the tonemapper as well, especially for indoor/outdoor transitions.

You may also want to manually place some other static point lights aside from the bounce card ones.

Or simply use a Lightmass that supports multiple bounces for skylights: https://forums.unrealengine.com/showthread.php?140006-Lightmass-multi-bounced-sky-lighting :slight_smile:

I’ve tried it but I don’t see any difference. I put num indirect lighting bounces on 10 in the lightmass settings. Did i miss something?

That’s somehow interesting. Did you see something like “Skylight bounce 1/10” in the SwarmAgent log window when you use that?

Yeah it’s in the log but it doesn’t look any different:

Are the materials in the scene have BaseColor > 0.8 ? (The implementation is physically-correct, means that low material reflectance can reduce bounced lighting brightness quickly; however you may increase “Diffuse Boost” in the lightmass settings to make it brighter)

Looks like that game has no diffuse map.
To me feels like they’ve use base color as emissive only; emissive color + normal maps, no color map.

Increase indirect lighting intensity multiplier in a post process volume.

There’s some info in here:

http://the-witness.net/news/?s=texturing
http://the-witness.net/news/?s=lighting

I’ve read through all of that several times and they do some custom things that as far as I know aren’t possible in unreal engine.

try increase the lighting bound multiplier or using the GI in post-processing might help

I don’t understand why you say that;
This game is made with Unreal 4:

https://youtube.com/watch?v=PU4vY0rlOo8

With the multi bounce skylights and some tweaks of the post processing effects like exposure, it should be pretty easy to get similar results. The only tricky part would be trying to get that tunnel exposure to work just as well/similarly enough.

Yeah but that doesn’t look as good as The Witness, it doesn’t even look like they use GI. You can’t compare them based on their art style.

I think you are right about the GI - global illumination should lighten those shadowed areas.

Things that might help:

  • reduce the ambient occlusion factor (pipe white-ish textures into there)
  • add a small amount of emissive as a darkened copy of your albedo (diffuse) texture

It might also help to decrease the slope value in your post processing volume settings.

Thanks for all the suggestions guys. I’ve applied most of them and managed to get a slightly better result. Although there’s still some dark shadows that I can’t get rid of. It seems to be caused by the directional light, because when I turn off “cast shadows” it looks better, but without shadows.

Here’s with cast shadows turned off and with only a skylight

Those just look like overlapping UV map issues. That coupled with too low res lightmap will cause seemingly random black faces like that.