Trees, Plants and Lighting

Hi. I need some advice regarding the rendering of trees etc.

Opacity-Masked leave textures look very off with default lighting, producing very bright areas next to very dark ones. This also causes individual polygons to clearly stand out, which looks even more artificial. I guess the problem is, that light doesn’t shine through to the other side of a leave like it normally would. And indirect scattered lighting is probably missing, too.

When I disable lighting completely, these problems are gone. But that’s not really satisfying either.

So, how can I make a material that will look good in this case?

instead of masked, try “two sided foliage”
which is… well… for two sided foliage.

I remember that there was a ‘Two Sided Foliage’ option somewhere, but now it’s gone? I can’t find it under Blend Mode or Shading Model. For my foliage I have Blend Mode == Masked, Shading Model == Two Sided + ‘Two Sided’ checked.

Am I missing something? :slight_smile: Was it removed or something?

yea, I think nowadays it is just called two sided.
I dont think you have to enable the seperate “two sided” option, but I am not sure.

it is rather confusing yea… Ill forward it to someone from epic to see if they can change the name a little.

Even as two-sided, my trees still look pretty bad :confused:

I guess it’s not easy finding good trees with LODs.

Hey MaxPower42,

I’d be happy to take a look at your set up. If you could provide me with a screenshot of your material(s) and of your trees placed in your scene, I can gauge where you could be going wrong or if you are overlooking a step.

Thanks,

Andrew Hurley