Toggle visibility hidden actor still casts shadow

I have a script in the level blueprint that randomly toggles visibility of certain objects. The problem is when they are not visible they still cast a shadow. How can I hide both the actor and the shadow?

Thank you all!


There is an option “cast shadow” which if not turned off the object WILL cast shadow… /even if the object’s visibility is turned off!!/


Thank you so much!! will check it out!

Using UE 4.26.2.

True this!

Can, via BP’s, turn on/off “Cast Shadow” which will turn on/off shadows caused by “Hidden Actor” being enabled.

For my game the player plays in first person; however, the shadow and what the other players see is a third person character. This third person character can be one of three different looking characters. Therefore, I have to set both “Visibility” and “Cast Shadow” for the desired player character for both others to see and for shadows to work as desired.

Thanks Makigirl!