Thumbnail turns black in forward rendering

How to reproduce:

  1. Enable forward rendering
  2. Click to open any of static mesh in Content Browser
  3. Thumbnail image turned black in Content Browser

It happened only when forward rendering is on.

Hey imskull,

While testing I did verify that the thumbnails did get much darker, but I never got a solid black thumbnail. Either way this is an issue that I decided to log here: Unreal Engine Issues and Bug Tracker (UE-42376)

You can track the report’s status as the issue is reviewed by our development staff. Please be aware that this issue may not be prioritized or fixed soon.


Ed Burgess

It is weird, our level artist got solid black thumbnails(excepting a white bar on top), but for me and another developer, it was just darker than normal. It is really a pain for our level artist to select object now, hope it will be fixed ASAP, a workaround or source patch are welcome, thanks.

I just found it got darker when using higher rendering quality(by Engine Scalability Settings)

I apologize, I’m unaware of any workaround to assist in this situation. I will add a private comment to the devs mentioning the impact this is having to our users.

I have same problem. Eveything became black after switching to forward rendering.

Just another note, if you use forward shading the material editor WILL ACTUALLY BE THAT DARK (if you use cube preview, 3 sides of the cube will be pitch black), while even tho mesh preview/thumbnails are dark, persona editor looks fine when opened fully.

This happens because of an ambient cubemap that is used to render the thumbnail which is set in the postprocess. Ambient cubemap is not supported in forward rendering mode.
I can only guess that changing it to a skylight would be better, didn’t try myself yet though.

Code to pinpoint:

void FThumbnailPreviewScene::GetView(FSceneViewFamily* ViewFamily, int32 X, int32 Y, uint32 SizeX, uint32 SizeY) const (UE_4.15\Engine\Source\Editor\UnrealEd\Private\ThumbnailHelpers.cpp, line 132)

FFinalPostProcessSettings::FCubemapEntry& CubemapEntry = *new(NewView->FinalPostProcessSettings.ContributingCubemaps) FFinalPostProcessSettings::FCubemapEntry;

CubemapEntry.AmbientCubemap = GUnrealEd->GetThumbnailManager()->AmbientCubemap;

When i disable Forward Shader, decals no longer work. Does someone know what other option might resolve the decal render, until FS is fixed?

I know DBuffer Decals are supported do you have that option enabled in your project settings? If not enable it and make sure to change the material blend type to DBuffer applied to all your decal actors as well. :slight_smile:

If you are using DBuffer Decals and it isn’t working please make a new post and I will investigate further.



this Black thumbnail is just asset floor plane that is dark.

For a temporary quick fix, we did increased directional light intensity and changed it’s rotation in FThumbnailPreviewScene::FThumbnailPreviewScene().
After that, assets are at least somehow visible.

I have the same problem. It is almost impossible to work properly when all the assets looks almost pitch black in the content browser. Please fix this ASAP.

1 Like

I have the same problem. . bummer

Same problem here, really really annoying. A very quick workaround would be just to have an option to use Unlit thumbnail images.

It has nothing to with floor being dark, floor is dark because AmbientCubemap does not work in forward render, see my reply above your’s.

Same problem here…this is really almost a show stopper for VR devs. Hoping for a fix soon.

Is there a progress update for this issue please? The issue says it is targeted to be fixed in 4.17 but is still marked as unresolved. If there is a fix pending for 4.17 that would be excellent.

This is effectively killing the ability to ‘browse’ in the content browser when using the forward renderer and our artists are finding it a real pain.

There currently isn’t a fix out for this. You will know if there is when the status is changed to fixed.

It’s unfortunately still a problem. Not only the thumbnails are very very dark, but the overall colour quality is lower.

I klicked randomly the “Quality” buttons on the top and my thumbnails went bright again. Also the the mesheditor has its Background image. Hope it works for you too