Things Disappearing in VR

I’m having a weird problem. Seems like maybe a bug. I’m prototyping this Archer shooting gallery game, where animal targets move around the scene on tracks. It all is seemingly working fine. When I hit simulate, everything moves around the tracks as it should. However, as soon as I view it in VR, something strange happens. The Bear and the Deer disappear. The first dear goes by, but the other 3 never come. And the bear goes into his cave and never comes out. If I delete the front of the bear’s cave, so I can see him the whole time, he goes in and out as he should. But if the cubes are there, and he leaves my view, he never comes back out. I can perform a similar test with the deer. It’s almost like it’s doing some culling but then forgets about them or something. Anyone ever experienced something like this?

So I turned off Culling in my project render settings, and that solved my problem. However, my new problem is that I imagine that will give me pretty significant performance hits when I start to build out my level with final artwork. Now that I know it’s a culling issue, is there something I can do to fix it besides turning off culling completely?

have you tried creating a Cull Distance Volume?