The bug "UE-11026" has gotten worse - Orthographic visual effects are broken

I have been trying to make an orthographic 3D game (uncommon, I know) in Unreal. I was presented with unreal’s orthographic lighting issues a long time ago and have until now been able to simply work around them by positioning a camera very far away and giving it an FOV of one. This has sadly lead to many other issues, and I would really like for the main one to be fixed.

What I’m seeing, according to my research, is something very similar to UE-11026 - except that, instead of just the directional light being broken (as it has been since 4.6, infuriatingly), almost every type of dynamic engine light and effect is broken in orthographic mode now. Static lights still work, but are useful for very little in my project.

The following examples all use very simple geometry.

Here is a point light in perspective mode:

Here it is in orthographic mode:

Here is a spot light in perspective mode:

Here is what I see in orthographic mode. Ignore the different size, I cropped a new image so you’d know I wasn’t using the last one again:

Finally, here is the directional light in perspective mode:

Here it is in orthographic mode, which at least makes an attempt this time:

Finally, here’s an example where I try to make a fairly nice looking scene by:

  • Making the floor reflective (water)
  • Adding a sky light
  • Giving the player a point light, like before

Orthographic mode does not improve the game, or give it the 2D pixel art effect I’m going for - it simply ruins my scene. No lights seem to be considered apart from the directional one, there are no shadows, and there are no reflections. There are no shading effects at all beyond simply rendering the shapes.


Create a project, and disable static (baked) lighting in the project settings. Set up any orthographic camera in a scene with any lighting you want, and try to get a shadow to appear. If possible use the same camera angle I’m using here - 45 degree tilt from above. This is not difficult to reproduce and I believe it’s known of already. I’m just bringing it to the staff’s attention again because of how bad things are now.

Hey Sixmorphugus,

I apologize that the orthographic projection is having issues. I know it can be pretty frustrating trying to develop a game around this. Have you tried using a perspective camera with the FOV set to 10 or lower? Having a very low FOV can fake an orthographic projection the downside is your camera has to be very far away. You can increase the distance on the near clipping plane in the project settings to help with this.

That is really the only thing I can offer that will give you immediate results. Thank you for voting on the issue it won’t mean that the issue will be escalated or fixed but it does show the community interest which we do pay attention to. It just can’t always influence our road map as there are so many things to take into account.

I’ve been doing that for now. The problem with having to fake “orthographic” rendering with a perspective camera is that certain features assume that, because the camera is far away, things should be rendered in low detail. For example, screenspace reflections:

I’ve got other things, like shadows, working at a decent level by attempting to use 10 shadow cascades (max cascades increased) but I’m worried about the performance impact of something like that. I don’t know what I can mess around with to try to get screenspace reflections to take FOV into account, so I’ll probably just have to leave all reflections out of my game for now.

Apologies for the irate tone of my original message; I had spent a week fighting with these bugs and trying to get things to work properly.

On the subject of community interest, however; UE-11026 now has 60 votes, making it (currently) the most upvoted backlogged bug on the issue tracker.

I know unreal is a primarily 3D engine, and understand that those aspects are the ones that both the developers and the community will be most interested in, but there is a lot of lost potential if practically the most important 2D feature of the engine doesn’t work properly.

hmmmm, maybe you can try out planar reflections? You could try these settings

Normal Distortion = 0 (this will prevent the reflections from being way off due to depth precision issues)

Prefilter Roughness = 0.01 (this seems fine for me but you will need to tweek)

Distance from Plane Fadeout End = 1500

Screen Percentage = 100

Extra FOV = 1 (increase this a tiny bit if you notice clipping on the the top and bottom)

This will hurt performance but considering your assets don’t seem too demanding on the GPU it may be okay. You will just have to profile your game using the GPU and CPU profiler tools. We have a pretty good youtube video by Zach Parish talking about profiling here: Rendering Best Practices | Live Training | Unreal Engine - YouTube

I hope that helps!

Alright. Thank you very much for your time. I’ll try those settings out.