Download

The asset failed to save

I’m having trouble in the editor. After working on a blueprint for a while (even compiling it, and running it PIE) when I try to save it a message comes up:

The asset ‘/Game/Blueprints/PonteDelDiavolo/PonteController’ (PonteController.uasset) failed to save.

Cancel: Stop saving all assets and return to the editor.
Retry: Attempt to save the asset again.
Continue: Skip saving this asset only.

It comes up again if I retry, or the next time I try to save. The log file also describes the problem but doesn’t add a lot of detail:


LogSavePackage: Save=43.699215ms
LogSavePackage: Moving '../../../../../../Users/ascii/Documents/Unreal Projects/Ponte_del_Diavolo/Saved//PonteControllerA7C8975B48F2E6869CF7328BE590BF27.tmp' to '../../../../../../Users/ascii/Documents/Unreal Projects/Ponte_del_Diavolo/Content/Blueprints/PonteDelDiavolo/PonteController.uasset'
LogFileManager:Warning: DeleteFile was unable to delete '../../../../../../Users/ascii/Documents/Unreal Projects/Ponte_del_Diavolo/Content/Blueprints/PonteDelDiavolo/PonteController.uasset', retrying in .5s...
LogFileManager:Error: Error deleting file '../../../../../../Users/ascii/Documents/Unreal Projects/Ponte_del_Diavolo/Content/Blueprints/PonteDelDiavolo/PonteController.uasset'.
LogSavePackage:Error: Error saving '../../../../../../Users/ascii/Documents/Unreal Projects/Ponte_del_Diavolo/Content/Blueprints/PonteDelDiavolo/PonteController.uasset'
EditorErrors: New page: Save Output
EditorErrors:Warning: Warning Error saving '../../../../../../Users/ascii/Documents/Unreal Projects/Ponte_del_Diavolo/Content/Blueprints/PonteDelDiavolo/PonteController.uasset'


What might be causing this, and what can I do about it? The BluePrint editor doesn’t even have a “Save As…” option so I could try a different file path. (Why not?)

OK, I think I discovered what was wrong. It turns out that I had accidentally launched the editor twice (it was waiting at the dialog box saying I had files open in the last session, and asking did I want to reopen them).

Perhaps the launcher could check for this and prevent it (or at least, ask if its what you really meant) since this doesn’t appear to be a very useful mode of operation.

7 Likes

haha, had the same problem, thanks :slight_smile:

2 Likes

As long as I can still run different versions at the same time I’m happy. :slight_smile: But yeah, don’t really need 2 of the same version running.

Thank you! I did the same thing.

It’s SO EASY to do that by accident. I’ve opened it twice for like 4 times now. When you hit open there’s no indication that the editor is opening. Then you either realize a minute later that “Oh, it wasn’t opening” or “Oh, nice, now I have two of them open”. That is… if you realize.

2 Likes

Ahh, this got me too. thanks

1 Like

Hey my problem was that my model wasn’t in the same folder as the textures, etc. Hope this helps some peeps.

just lost day of work because of this :frowning:

Autosave, and press ctrl+S every time after you compile.
Then every time you test game or add major feature zip project folder and do backup, add name of feature in zip file filename.
This all helps.

unfortunately my last zip backup was from yesterday :stuck_out_tongue:

I let my self post this feature request

Happened to me too :smiley:

why would you bump a thread from 2 months ago only to say it happened to you?

There is another case. If your file is read only, like you copy from other project controlled by some source control tools, it happened.

There is another case. If your file is read only, like you copy from other projectcontrolled by some source control tools, it happened.

I also this!

LOL OMG OMG OMG, I feel so stupid! thanks man <3

lol funny happend to me too, and I felt so stupid, but then I saw the comments and felt less stupid. LOL adding one more to the LIST! don’t feel stupid people!

hahah meee toooo xD

I had this problem too. The file was deleted in UE4 but then I re imported the file and tried to save it and I would get this error.

I reverted the file in Perforce and tried again. this fixed the error.

Omg thank you! Totally saved me :slight_smile:
Thanks a lot for the help