Textures stuck on low resolution in UE 5.4

As of UE 5.4, some of my textures are stuck on being displayed at 64x64 resolution, even though Max texture size is not set to 64. I can fix this if I mess around with the max texture size parameters or by deleting the DDC. Obviously these solutions aren’t ideal since it’s often difficult to tell if a texture is being displayed at the full resolution or not, for example for AO/Roughness/Metallic textures. Deleting DDC fixes it temporarily, by the issue starts happening again later as I load more assets into the viewport.

Here’s an example of a texture imported as 4k, but being displayed at 64x64 even though max texture size is 0:


When I set max texture size to 4096, it fixes it:


Does anyone know an easy way to fix this? Is a known bug that Epic is aware of? Thanks!

1 Like

There’s a lot of people ( including me ) complaining about this.

Setting the texture to ‘sharpen0’ fixes it, although not the solution.

I read something the other about which indicated that the Oodle texture plugin was possibly causing issues, but can’t find that post now. You might see if disabling that fixes it?

Thanks for your reply, disabling Oodle fixed it! Is there any downside to disabling Oodle, like textures looking different etc.?

2 Likes

I don’t really know much about it, I think it’s a better compression algorithm, possibly also faster. So things should work as normal, but may take more VRAM.

2 Likes

I’ll be interested to see if this solution holds… :slight_smile:

1 Like

Seems good so far, textures seem to be same as before. I’ll update if anything looks off

2 Likes

Can anyone try to disable either the zenloader and/or texture streaming and see if that corrects the issue?

[/Script/Engine.EditorStreamingSettings]
s.ZenLoaderEnabled=False

[/Script/Engine.RendererSettings]
r.TextureStreaming=False

1 Like

(post deleted by author)

Ok, believe it or not, it just happened.

Neither console command had any effect.

First symptom is seeing very fuzzy textures in the environment, only affecting particular assets. On hunting down the textures and materials those assets are using, you’re confronted with this

Changing almost anything ( my favourite it sharpen0 ) in the settings and boom

The only pattern I’ve noticed is that it will affect all the textures for a given material. So albedo, normal and anything else for a particular material. Also it’s most likely to be materials you haven’t seen for a while, maybe a level you haven’t worked on recently…

Looking at the normal for this same material gives the same thing

This has something to do with texture compression. All textures have a zero cache ID. If you forcefully generate this ID, it will solve the problem. But how can this be applied to the entire project if it has several thousand textures, I don’t know?
Before

After

1 Like

Right, so quite possible related to Oodle? Somehow the cache ID is getting invalidated.

Hmmm, but I see textures that are totally fine, with a 0 cache ID.

There’s an update Oodle button, and that fixes it too.

image

1 Like

Can anyone having the issue can share their editor logs with us?

1 Like

I will next time it happens. I recall there was nothing obvious in there :frowning:

Here’s a log of the issue, the low res texture is TA_RockAssembly_08_BaseColor, but there isn’t too much in the log about this asset
AH_Ch2_Act1.log (306.4 KB)

1 Like

Hi @UE_FlavienP, I can second this about the logs, there is nothing in there about textures whatsoever :slight_smile:

I had it again just now with a Megascans material / texture.

Click the Ooodle ‘latest’ button and

Although, like I say, setting Sharpen0 has the same effect… :thinking:

Disabling “Oodle Texture” plugin fixed it for me. :grin:

1 Like

@UE_FlavienP

A little more on this. I don’t know if you’ve seen this thread

For some reason in this version of the engine, there is a constant hitch during play, about .5 seconds. The @zeaf solution does seem to help this, and involves the loader. Here’s what that hitch looks like in insights

Curiously, turning off streaming does also fix the hitch.

I haven’t had the problem with miniature textures for a while though, so unable to see what effect these have on that, but this all seems related… I’m not sure how useful this info is :rofl:

Ok, finally I had the mini-textures again. This time I restarted the engine without texture streaming. Very bizarre.

The textures are the right size, but empty. This is supposed to be bark

If I restart again with streaming, I’m back to the mini-texture

Disable Oodle plugin, and restart. Back to normal