Textures look washed out in viewport but not in material editor

Textures on all my assets look washed out for some reason.

Here is the original texture:

and here is the in viewport asset with the texture on it:


The Material is just the diffuse with an alpha mask and nothing else plugged in. Its the default 3rd person template with no added post process stuff or lighting.

You need to play with the roughness input, try a full black (vector 1 set to 0) which will make it look way less washed out.
Dont forget that on import the texture might have been set to SRGB so double click on the texture (not the material) and see if that changes anything.

Let me know if you need more help.

It isn’t as washed out with a value of 0 in roughness but it is very reflective and thats not what I need for this. SRGB is unchecked and in the material its set to linear color but that made it just as washed out in the material editor as it is in the viewport.

Hello KrunkFu,

If you are using Lightmass, try changing the ‘Environment Color’ to Black instead of White. This could be what is washing out your material in the world.


It was set to white so I reset all lightmass settings and rebuilt lighting but it made no difference at first. I started a new project in the newest preview build and reimported some stuff to see if there would be a difference and there was.

There was and it looks better. I went back to the old version and everything was fine in there too. It must have been the lightmass settings but I don’t know why it didn’t show up properly after building lights.

Thanks for the help!

You may also want to make sure it has a reflection capture actor near it, that helps to remove the blueish sheen on materials.