Download

texture streaming?

Sorry but I do not understand how to fix this …

When I play in the editor the level runs smooth even if it gets this error message, but when I play of editor when built , the texture stremaing seems doubled and it lags heavily , I used all textures and materials from megascans quizel … how I can do to reduce tecture streaming and making the exe esperience smoother?

It just means the default GPU memory allocated to texture streaming has run out.

The default is quite low ( 1GB I think ), you can increase it with a console command ( to open the console hit ` ):

r.Streaming.PoolSize 2000

( or more ). Obviously if you have to jack the number up to a ridiculous amount, you might want to figure out what’s going on, but you’re only a tiny bit over here, so don’t worry.

Also, when you export the game in production, it will automatically use all GPU memory, and you don’t get this error.

Ok I actually Used textures from Megacans pbr materials , from Quixels, I didn’t care much at when I downloaded materials and I downloaded all at max resolution thinking that the game would may be create mipmaps or downsized versions for the textures, it doesn’t ? Anyway I went into ome of the folders source files from double clicking on the texture and selecting the path texture, opening in PS , resizing, saving and linking to it, but in the texture top info always says 4 k instead of 1 k as I saved … is this normal? I tried to reload also the editor but always shows as 4k…
That said anyway I packed all exported for win 64, I also edited the ini file for Engine to have a max 4000 k texture streaming , but when I entr a particular area the game lags … Since I reduced textures and I get not this message what can it be?
Btw I also have a large mp4 file played in stream on the cinema hall I have in the level .

Hi, don’t do this. Set a Lod bias in UE for the texture if you want to downscale it, then you can always use a higher resolution again without doing such a crazy workaround :slight_smile:

And make use of texture groups, since you can add a Lod bias also for a whole texture group at once (so don’t put them all into World since that will make scalability harder).

It does. But when you’re close up it will stream in higher resolution mip maps.

Make use of UE profiling tools and stat commands. First way would be the console commands “stat unit”, “stat game”, “stat gpu” and then continue from there depending where your performance problem is.

Sorry I didnt understand the last part can you explain me better or point me to a tutorial video?
Thanks a lot.

Ok, as for tutorial, this maybe https://www.youtube.com/watch?v=hcxetY8g_fs although this covers the whole process, so might be too in depth here.

And I can try to be more precise:

(1) start game in standalone

(2) go to where the frame rate is low

(3) open console

(4) type stat unit hit enter

(5) repeat (4) also for stat game and stat gpu

[HR][/HR]
“stat unit” will give you a first overview how your performance looks like. It displays the time that the main threads use up per frame. They all execute parallel so your actual frame time will be the highest of those times. If your Game time would be the highest you should look into “stat game”. If you’re GPU time is highest, look into “stat gpu”.

This is what I am getting … but how I see why and what do those numbers mean?

https://i.gyazo.com/3d4dcfbf39a6c231…8f9c45fe06.png

Disable Ray Tracing, if you still have performance problems reduce the number of movable lights.

EDIT: If you only have performance problems in this specific area, then first reduce the number of movable lights there and then disable ray tracing if necessary. But generally speaking with today’s hardware you should be careful about using ray tracing and then only enable specific features, since ray tracing will have a huge performance impact.

I set all lights to static now … how I disable raytracing?

In the project settings under Rendering uncheck “Ray Tracing”, then restart the editor. It will then have to recompile all shaders, so it might take some time to start.

I disabled raytracing but then I got this message …

I had to reenable Raytracing couse it messed all my level without textures.

Never had this problem. Do you use some preview engine version or compiled the engine on your own?

Dunno what it is… I just run the installed editor…