Texture disappears when using opacity mask to create a hole


I want to create a hole in the landscape as a starting point to create a cave. I’m following the article at Landscape Sculpt Mode in Unreal Engine | Unreal Engine 5.2 Documentation

My ‘Hole’ material is exactly the same as my Landscape material, except for the Blend Mode set to Masked, and the new Landscape Visility Mask node:

When I tried to apply the ‘hole’ material to the landscape , the quad where I click loses the texture as you can see in the viewport:

Shutting down the editor and opening it again to recompile the shaders doesn’t fix the issue. Does anybody know why is this happening? Is it a known issue?

Hi ,

  • Does this occur in a clean, blank project with no additional content or is it limited to one project?
  • How many textures/layers do you have painted onto the landscape component?
  • Have you tried re-painting on the component to force an update?
  • Have you tried pressing the build button to force an update?

Hi ,

We have not heard from you in several days. I am marking this as answered for tracking purposes. If you are still experiencing this error, please comment with the requested information.