Temporal Super Resolution Problem

Hello Guys,

I`m working on a project of 3d animation based on Unreal Engine 5 with an post apo world like the Last Of Us ( No video game ) with the tool Brushify

TSR ON : Distance Foliage are perfect but in a close view the grass is blurry

TSR OFF ( or any other filter ) Distance flickering of foliage and the grass is OK ( but far from the grass of the last of us )

Thanks for your help

1 Like

Is the grass set to moveable? 5.0 has an issue where static meshes will not output velocity, resulting in intense smearing if you try to animate these meshes with WPO.

thanks for the information

This is Brushify pack I guess? I personally can’t figure out a way to set all grass meshes to movable.

My trick would be TSR + Use ‘Write during base pass’ for Velocity Pass (under rendering setting). Credit to: WPO issue in UE 5.0 on all materials, severe smear/dither - #10 by flankey

It is a hard fix but good news is that dev team is internally tracking this issue and let’s hope it gets fixed in next version.

Any other tricks you might know to get this to work with procedural grass? Or will we just have to wait until they fix it :frowning:

Any news on this? having the same problem as i describe here, it is already “Write during base pass”.

Seems like the same problem with HISM-s, even if it’s not foliage… it’s UE5.1.1 and “Velocity Pass” to “Write during base pass” has no effect on it.

Epic doesn’t really give a ■■■■, right?

1 Like

So apparently this effect is not present when you use the camera instead the viewport .

TSR cannot handle foliage yet. Even when you turn on output velocity on the foliage material, it will still ghost maybe because you don’t have a high enough resolution(TSR feed) or have enough frames per second (TSR 1spp).

Read this below

Because you have a heavy foliage scene, I suggest you switch to TAA from TSR instead Project settings>AntiAliasingMethod

Because TAA WILL ACTUALLY take into account of “output velocity” in foliage material.
At 4k leave the TemporalAA Cvars on the default and use “r.Tonemapper.Sharpen .5” This is what was used with Lumen in the Land of Nanite(which was at 4k)