Swarm Agent - hangs, doesnt work

I discovered this one day when trying to build the light in a 4.9 project. The lighting would never build and the editor would report it couldn’t connect to the Swarm Agent after waiting for a few minutes. Same thing in 4.10. I’ve tried old projects, new projects, full content projects, empty projects - no matter what conditions, the lightning never gets built.

I even tried UE3 and had the same results!

So the Swarm Agent starts, but then hangs. The log reads:

Starting up SwarmAgent …

… registering SwarmAgent with remoting service

… registering SwarmAgent network channels

… initializing SwarmAgent

… checking certificate

… certificate check has failed

… initializing cache

… using cache folder ‘C:\SwarmCache’

… recreating SwarmAgent cache staging area

… initializing connection to SwarmCoordinator

… using SwarmCoordinator on APPSERV

[PingCoordinator] Determined that we couldn’t ping the coordinator

[PingCoordinator] Coordinator ping failed

… SwarmCoordinator failed to be initialized

… initializing local performance monitoring subsystem

At this point, it hangs and nothing happens. I can’t even end the process, with Task Manager or even admin-access cmd.

If I try to run it again, I get an error about attempting to run a duplicate process - so I have to restart the PC just to try again. I’ve done this 20-30 times already. I’ve followed every Swarm Agent hanging solution I could find here on the Answer Hub. I’ve tried reinstalling each version of the engine, the engine program itself, all my graphics drivers, every recent program from the past month, my anti-virus. Tried every solution suggested and nothing has worked so far.

I’ve pretty much halted all my work at the moment as trying to resolve this issue has me pretty stressed out. If anyone can help me resolve this issue and allow me to return to rendering light like everyone else, I’d very much appreciate it.