Swarm Agent: [ERROR] Provider load failure (Light Build doesnt start)

Hi! I’ve had this issue for a long time now, but i haven’t been able to find a solution for it online, so far!
I’m really hoping someone in here can help with it!


Lighting build fails, Swarm Agent outputs: [Interface:OpenJob] Error: Provider load failure

Detailed Issue

When i attempt to build any project in Unreal Engine 4.10 build finishes quickly with Navigation build completed, it does not start building lighting, not even if i build lighting only.

Swarm Agent is opened, as i can see icon in taskbar. I can open Swarm Agent just fine by double clicking on it.

Im attempting to build lighting for One computer only, which is one im working on.

I did not have this issue before, i dont know which version it was, or what happened. Its a long time ago when UE4 was a paid subscription based software.

Im not trying to get Swarm Agent to connect to anything. All Swarm Agent settings are default after a fresh reinstall.

Reproducing issue

Im gonna reproduce issue with default Blueprint FirstPerson Shooter Example Project, by placing a light in Example Map, and hitting build. Before i do so, i make sure any other instances of Swarm Agent, and Swarm Coordinator is closed, and then i manually open SwarmAgent.exe, and open Log tab, which outputs:

13:27:39: Starting up SwarmAgent ...
13:27:39:  ... registering SwarmAgent with remoting service
13:27:39:  ... registering SwarmAgent network channels
13:27:39:  ... initializing SwarmAgent
13:27:39:  ......... certificate check has failed
13:27:39:  ...... initializing cache
13:27:39:  ......... using cache folder 'D:\Program Files\Epic Games\4.10\Engine\Binaries\DotNET/SwarmCache'
13:27:39:  ......... recreating SwarmAgent cache staging area
13:27:39:  ...... initializing connection to SwarmCoordinator
13:27:39:  ......... using SwarmCoordinator on RENDER-01
13:27:41:  ......... SwarmCoordinator failed to be initialized
13:27:41:  ...... initializing local performance monitoring subsystem
13:27:42:  ... initialization successful, SwarmAgent now running

I then proceed to hit Build inside Unreal Engine 4.10. Swarm Agent clears current log, and outputs:

13:27:59: [Interface:TryOpenConnection] Local connection established
13:27:59: [Interface:OpenJob] Error: Provider load failure 

NOTE: This was reproduced using default blueprint first person shooter example map

NOTE: Reproduced using a Single computer. Im not trying to have Swarm Agent connect to anything else. Im working and rendering on same computer.

Here is Swarm Agent Log file after reproducing issue!


I have attempted several things to get this working:

  • I have double checked that i have latest .Net Framework 4.5.2 installed and activated on this computer! I have also attempted to install latest version of .Net Framework from




But because this is Windows 8.1, which comes with this .NET Framework, installer is telling me its already installed.
As far as i have seen, there is no way to uninstall or reinstall this .NET framework, because it is implemented into OS.
Screenshot - d10954b9740cafb60a799f0fa55dcddf - Gyazo

  • I fully reinstalled Unreal Engine by uninstalling Epic Games Launcher, and deleting anything associated with Unreal or Epic games in Program-Files and AppData. I also proceeded to remove all history of Unreal Engine, Swarm Agent and Swarm Coordinator from Windows Firewall and Windows Defender, to make sure i got prompted with Network Permissions when reinstalling Software!

  • I have made sure that i dont have any Anti-Virus software other than Windows Defender and Windows Firewall, and made sure that both Windows Firewall and Windows Defender is letting Swarm Agent, Swarm Coordinator and Unreal Engine through!

  • I have attempted to reproduce issue on another computer with a fresh and clean installation of windows, only having Unreal Engine 4.10 installed. build worked just fine, without any problems on the other computer, however that computer is not powerful and is not prefered when working.

  • I have tried other versions of Engine, aka: 4.9.2, 4.8.3 and 4.6.1 on my main computer, all of them are having same issue with Swarm Agent!

  • Made sure that Swarm Agent and Unreal Engine are running on default settings after reinstall.


Short video showing issue reproduction on both FPS Example map, and Default Map performed on main computer with all settings set to default with Example First Person Shooter Project.


Computer with issue: (Desktop PC)

Windows 8.1 64-bit
Asus ROG Maximus VII Ranger Motherboard
Intel Core i7-4790K LGA1150 Processor
16384MB RAM
SSD 128GB (OS)
HDD 2TB (Unreal Installation)
3 Monitor setup:
BenQ G2420HD x2
Asus ROG Swift PG278Q

Other Computer: (used for debugging) (Tablet PC)

Microsoft Surface-Pro 3
Windows 8.1 64-bit
Intel Core i7
SSD 512GB (OS / Unreal Installation)
8GB Ram
Intel Integrated Graphics

I’ve had this issue for some time now, and im out of ideas of how to fix this.
Im hoping someone in here can help me out!

Hey AquaRex,

Thanks for details and all steps you’ve tried so far. That’s really helpful.

Here are things I would like you try at this point and see if it resolves your issue.

Completely disable your Antivirus/Firewall and try to build. This can rule out any exception issues.

Restarted editor and try to build lighting for scene.

Open Swarm Agent from Task Tray.

In the Settings tab with the CacheFolder location change this to C:/Swarm/SwarmCache (You will need to create this folder.

Now restart editor and try to build lighting.

In Main Menu for Swarm Agent click on the Cache option and select Clean and then Validate.

Try to build lighting in your project.

Make sure you have correct dependencies installed.

If you’re using 4.9 or earlier use these for VS 2013: http://www.microsoft.com/en-us/download/details.aspx?id=40784

If you’re 4.10 or later use these for VS 2015: https://www.microsoft.com/en-us/download/details.aspx?id=48145

You can verify which versions you have installed in your Control Panel > Installed Programs list. Even if you have them installed it may be helpful to reinstall these.

Now Restart your computer, launch editor and try to build lighting.

As for the .NET Framework. latest version I have installed is 4.6. I also have 4.5.2 .NET Framework installed as well.

You can get 4.6 .NET Framework here: https://www.microsoft.com/en-us/download/details.aspx?id=48130

You can see which versions you have installed in your Control Panel > Installed programs list. It may be good to try reinstalling these to rule out this as an issue as well.

After this, restart your computer, launch editor and see if lighting will build.

If any of these resolve issue I can update our Swarm Agent Troubleshooting Guide that I’ve written to include this information. I’ve not run across this issue before, so hopefully one of these will get your issue resolved, otherwise I may need to do a little bit more digging to see what’s going on.

Thank you!


Thank you for your answer Tim!

I’ll do debugging suggestions you mentioned, and post results below in hope that you can get a better understanding of why it doesnt work!



Disable Antivirus / Firewall and build.

Result: Failed - No change


Change Cache folder location, then restart and build.

Result: Failed - No change


Clean and validate SwarmAgent cache and build.

Result: Failed - No change

Log output:

01:33:15: [RequestCacheClear] Request ignored because of active, open connections
01:33:16: [RequestCacheValidate] Request ignored because of active, open connections
01:33:18: [Connection] Detected new local connection from same process ID as an existing one, closing old one
01:33:18: [CloseConnection] Closing connection 034300C9 using handle 034300C9
01:33:18: [CloseConnection] Connection confirmed for disconnection 034300C9
01:33:18: [CloseConnection] Closing orphaned Job ()
01:33:18: [CloseConnection] Connection disconnected 034300C9
01:33:18: [GetMessage] Safely returning to 034300C9 with no message
01:33:18: [Interface:TryOpenConnection] Local connection established
01:33:18: [Interface:OpenJob] Error: Provider load failure 
01:33:18: [MaintainConnections] Local connection has closed (034300C9)
01:33:18: [MaintainConnections] Removed connection 034300C9

Picture of log:


Vertify and reinstall VS versions, then restart + build.

Result: Failed - No change

Note: Im unsure if i need all of VS instances installed, or if its safe to remove them.
They’ve built up over time i guess.


Installing .NET 4.6, then restarting + build.

Note: .NET 4.6 was already installed according to installer, so i uninstalled Windows update:

Microsoft Windows (KB3045563)

and manually installed .NET 4.6 from installer Tim provided.

Result: Failed - No change

Sidenote: .NET Framework 4.6 isnt showing up in Windows Features window. Not sure if this is normal, or correct.

Sadly none of suggestions worked for me. Still havent found anything regarding issue anywhere else.
Heres hoping you can dig up something!

Best Regards


Thank you for trying all that. Unfortunately, I’m out of ideas at moment and with our Thanksgiving holiday. I’ll be able to dig into this a bit more next week once office is back in full swing.

As for dependencies, I have all previous versions installed from 2005 - 2015 without issue. Same for the .NET stuff.

Sorry I couldn’t be more help right now and thank you for your patience while this is being looked at.

Just wanted to update. I don’t have anything to add at moment, but wanted to let you know I’ll post back once I have more to add.

Apologies all, but currently we do not have developer support for this feature, and there is little we can do outside current functionality. Please feel free to continue offering feedback. Thanks for your patience and understanding.

Hi, i might be misunderstanding you, but what do you mean about there being little you can do outside current functionality? What im trying to do is build lighting, which to my understanding is a feature that is pretty important for functionality of Unreal Engine 4, and is within current functionality of Unreal Engine and Swarm Agent. For reasons unknown i cannot get Swarm Agent to build lighting for Unreal Engine 4. It always fails with: Error: Provider load failure. If and when any of you know more regarding this issue or have steps i can try that has not been suggested above, please let me know! This functionality is critical for me to be able to work on any projects in unreal engine, as i cannot build lights or light bounces.

Hi AquaRex -

Tim and I have been talking about your issue and have two more things to try. We have identified problem being a mis- or un- registered DLL file with the .NET framework.

First try following instructions on this Windows Knowledge site:


See if after you restart you PC and open Engine, if this will not correct issue. If it does not try this:

running Swarm Agent from exe file in Engine Install Folder as an administrator before opening engine.

Let us know -

Eric Ketchum

Thank you Eric, for bringing more suggestions for me to try!

I have done some tests with what i could do. Because i did not have Windows 8.1 Pro, i was unable to do your first suggestions. But i attempted to restart computer, and starting Swarm Agent manually as Administrator before i ran Unreal Engine 4.
result changed, it no longer stopped build like it did before, this time it provided an error: “Failed to connect to Swarm” However, this error message only appeared during first build attempt. Any attempts made to build after that left same results as before ( as mentioned in first posts ) However, i managed to retrieve log from build i did when i got a slightly different result:

23:19:29: Starting up SwarmAgent ...
23:19:29:  ... registering SwarmAgent with remoting service
23:19:29:  ... registering SwarmAgent network channels
23:19:29:  ... initializing SwarmAgent
23:19:29:  ......... certificate check has failed
23:19:29:  ...... initializing cache
23:19:29:  ......... using cache folder 'D:\Program Files\Epic Games\4.10\Engine\Binaries\DotNET/SwarmCache'
23:19:29:  ......... recreating SwarmAgent cache staging area
23:19:29:  ...... initializing connection to SwarmCoordinator
23:19:29:  ......... using SwarmCoordinator on RENDER-01
23:19:31:  ......... SwarmCoordinator failed to be initialized
23:19:31:  ...... initializing local performance monitoring subsystem
23:19:31:  ... initialization successful, SwarmAgent now runnin

( this time no red error messages in log )
log seemed more ‘green’ than before, but it still did fail to initialize.
Hopefully this can help you further to identify problem.
I am concidering to update all way up to Windows 10 Pro if i am unable to resolve problem, hoping that an upgrade will automatically resolve any problems i might have.

Best Regards

Hello AquaRex -

I am assuming you are on Windows 7, can you run Windows Update Program and install any updates listed specifically updates to .NET Framework files? Next open Swarm Agent and in Settings Set EnableStandAloneMode to True

Let me know results -

Eric Ketchum

No, im running Windows 8.1, with all latest updates installed. However 8.1 non pro versions dont have access to Local Security Policy Tool that Windows 8.1 Pro users do. However on my Windows 8.1 i checked that all updates relating to updates on .NET Framework has been installed.

I tried closing unreal engine entirely, aswell as killing all process related to Swarm Agent, to make sure it was not running. I reopened it as administrator, and changed EnableStandAloneMode to True, restarted Swarm Agent and Unreal Engine and hit Build, result was still: “Failed to connect to Swarm.” and this is log that came out of it:

12:38:57: Starting up SwarmAgent ...
12:38:57:  ... registering SwarmAgent with remoting service
12:38:57:  ... registering SwarmAgent network channels
12:38:57:  ... initializing SwarmAgent
12:38:57:  ......... certificate check has failed
12:38:57:  ...... initializing cache
12:38:57:  ......... using cache folder 'D:\Program Files\Epic Games\4.10\Engine\Binaries\DotNET/SwarmCache'
12:38:57:  ......... recreating SwarmAgent cache staging area
12:38:57:  ...... initializing connection to SwarmCoordinator
12:38:57:  ......... using SwarmCoordinator on RENDER-01
12:38:57:  ......... SwarmCoordinator successfully initialized
12:38:57:  ...... initializing local performance monitoring subsystem
12:38:57:  ... initialization successful, SwarmAgent now running
12:39:29: [Connection] Detected new local connection from same process ID as an existing one, closing old one
12:39:29: [CloseConnection] Closing connection 7A1C4C02 using handle 7A1C4C02
12:39:29: [CloseConnection] Connection confirmed for disconnection 7A1C4C02
12:39:29: [CloseConnection] Connection disconnected 7A1C4C02
12:39:30: [MaintainConnections] Local connection has closed (7A1C4C02)
12:39:30: [MaintainConnections] Removed connection 7A1C4C02

Hope this helps


Ok so we’ve made some process, now before opening Swam as an Administrator ensure that your Computer, AntiVirus, Firewall software is not blocking port 8008, or for that matter is allowing SwarmAgent.exe to correctly have access to any ports.

Eric Ketchum

Alright, so i did a couple of checks to ensure this wasnt case. I only have Windows Defender and Windows Firewall protecting my computer at this moment. I made sure that program was allowed through on both these programs, and made sure they were allowing through port 8008 by making exeptions for it. I then also disabled both of them to make sure they could not interfere. I then ran Swarm Agent and Unreal Engine, did a build test on a project, and i still got the “Failed to connect to Swarm.” error, along with log file:

To make sure i could write this within sites limited characters, i cut out part where Swarm Agent initializes. What you see below is what was added after i hit build. ( part before this is pretty much identical to log i posted before )

07:08:00: [Connection] Detected new local connection from same process ID as an existing one, closing old one
    07:08:00: [CloseConnection] Closing connection 4898A497 using handle 4898A497
    07:08:00: [CloseConnection] Connection confirmed for disconnection 4898A497
    07:08:00: [CloseConnection] Connection disconnected 4898A497
    07:08:02: [MaintainConnections] Local connection has closed (4898A497)
    07:08:02: [MaintainConnections] Removed connection 4898A497

I also did an additional check to see if port was running at all on my computer, and did a netstat -a -n command in a elevated command prompt. almost at top it showed TCP as a LISTENING state, then i did the ’ netsh firewall show state ’ command, which showed me this:

which shows that both TCP and UDP on port 8008 is allowed through and open.

This might trigger more questions than it answers, but i do hope it helps


Yes, this is Full Swarm Agent log after running Build twice (as running Build once did not generate any log at all)

08:36:05: [Connection] Detected new local connection from same process ID as an existing one, closing old one
08:36:05: [CloseConnection] Closing connection 0C887544 using handle 0C887544
08:36:05: [CloseConnection] Connection confirmed for disconnection 0C887544
08:36:05: [CloseConnection] Connection disconnected 0C887544
08:36:07: [MaintainConnections] Local connection has closed (0C887544)
08:36:07: [MaintainConnections] Removed connection 0C887544

Hi AquaRex -

Do you still get same Connection logs in Swarm if you do not have it running when you start Unreal and then build lighting?

Eric Ketchum

Hello -

I feel like we are getting closer to solving this one for you. I appreciate your patience so far.

So I want to have you do a little bit of engine temp file pruning, to make sure that nothing is causing residual problems.

If you can please go into C:\Users[User Name]\AppData\Local\UnrealEngine\ and (making sure that all versions of Swarm, Launcher and Editor are closed) delete all subfolders. There should be at least a 4.10 directory and a Common Directory.

Next go to C:\Program Files\Epic Games\4.10\Engine\ and delete DerivedDataCache, Intermediate, and Saved Subdirectories.

Note: These directories will be rebuilt when engine first opens again, so expect a longer than normal startup time.

Now open Swarm Agent from C:\Program Files\Epic Games\4.10\Engine\Binaries\DotNET\

In Swarm Agent, Click on Cache > Clean and then Cache > Validate

Close Swarm Agent

Open Launcher and go to Library, Validate 4.10 Engine Installation.

Once Validated, open your project and attempt to build lighting again.

Thank You

Eric Ketchum

Alright, so i did what you asked.
I removed subfolders you asked me to, then i cleaned and validated Swarm Agent Cache

I then verified Unreal Engine installation

However, after verification of Unreal Engine build was completed, i got this error message

I am not sure what is causing this, or why its appearing, but i continued on and engine launched correctly without any Apparent issues

I setup a new first person template and added a Point Light to make sure lighting on level wasnt ‘already built’ if that could make it skip process.
I then hit build, a popup showing build process working showed for a split second before closing telling me that

I opened Swarm Agent and check its logs, this is what i found

This appears to be same error i had in beginning, i then closed engine and swarm engine completely. Reopened Swarm Agent as administrator, and built again, this time build process shows a message:

And Swarm Agent log now looks like this:

I hope this helps give an insight to what issue might be.


Ok go into your Uninstall Programs / App and look for UE4 Prerequisites and uninstall it then try to verify your Engine again. It should verify and if it does then try to build lighting again.

Eric Ketchum

I do not have a UE4 Prerequisites in my Uninstall Programs / App. Keep in mind UE4 is installed on my D drive and not my C drive, if that matters. Is there a way to find this uninstall program somewhere?

Hi -

OK, lets take a different tack on same possible solution:

Got to Extras Redist Sub Directory (by default: C:\Program Files\Epic Games\4.10\Engine\Extras\Redist\en-us\

Install x86 and x64 Prereq Setup Files

Eric Ketchum