Download

Struggling with lighting artifacts

I’m relatively new to making environments so forgive me if I’ve made a stupid mistake :sweat_smile: .
I’m making an interior space with no windows. Where are these blotches (circled in the image) coming from? The lighting here was built at a medium level, but the blotches appear at every level. I’ve fiddled with the resolution of the lightmaps and adjusted the models many times but I always seem to get these blotches. I’m stumped. I’m using 4.25.3 by the way.

Any ideas why this is happening and how to fix it?

Thanks

Either the lightmap resolution is too low (unlikely), or the lightmap UVs are incorrect (most likely).

You should make a separate UV channel for lightmaps, and set that to be used in the Static Mesh asset editor.


This is the lightmap I’m using. I’ve remade them several times already and get blotches every time. :frowning:

What is the lightmap resolution?
What are the lightmass settings?

The lightmap resolution on this object right now is 520, cranking it up or down doesn’t seem to get rid of the blotches.
These are my world lightmass settings


and the lighting settings for the object (it has an emissive but it’s turned off at the moment)

I would say it’s a combination of your lightmass settings and the lightmap + its resolution!
Either break up the mesh into smaller parts or use a lot higher lightmap resolution… the tinier the island on your lightmap uv, the less lighting information it will get! …smaller than 1 pixel won’t get any information! The islands that are not perfectly aligned with texels /circular, diagonal…/ will highly possible give you bad results…
Your indirect lighting quality is on 4 which also not so high for a perfect result: it won’t give you enough samples in the scene for those small areas… smoothness is on 1 which will blur out the detals…

1 Like


So, these images are the result of turning the indirect lighting quality to 8 and separating the sofa into three parts (the wooden frame, seats, and seat backs). I’ve straightened out the lightmap UVs on the sofas as best I could. Here everything is built at “high.” (Ignore the fact I’ve changed some lights to movable. I was testing it. It doesn’t change anything.)

I know I have a lot of lights. I’ve tried turning some of the lights off (not in these pictures) but I still get artifacts. Even on the walls and curtains, where the lightmaps are very simple and straight.

Could you show please the lighting only view for the same 2 images?

Had similar unknown blotches in my latest bake.
Ended up ignoring them after poking around for 4 hours to debug.
Chalk it off to a bad engine. That’s exactly What it is.

It’s not the model.
It’s not the materials or their reflectivity.
It’s not reflection captures or their resolution.
It’s not uv maps or their resolution.
It’s not light bounces generated by lightmss.

And well, the last thing one could test is removing the light. But then it would bake black, so ¯_(ツ)_/¯

One thing I did forget to check (installing the latest atm so cannot verify), was the light complexity on that specific spot.

Maybe if somehow 6 lights are intersecting one can expect for lightmass to get confused or render badly regardless of what engine is used.

Obviously same exact scene in other engines doesn’t bake any artifacts (however the light setups may differ by design, so its not like saying much).


:frowning:

What happens if you disable shadow casting on all your lights ?

I guess that’s one test I should have done that’s basically almost like removing all the lights…

Now I can try it too :stuck_out_tongue:

That narrows it down.
its an artifact due to the directional light. The only light that was left casting a shadow.

@ehudroge Do you also have a directional light in the scene?

1 Like

That’s very strange!! It looks like low quality build! :S
I saw something similar in the past but they didn’t look exactly like these artifacts: is it possible that any of your lights is intersecting a mesh? …if you could try to disable ALL your lights and place one in the middle of the room…
…would it be possible to share your project privately?

1 Like


This is baked with no shadows on anything except the skylight.

I think I can safely say that the problem is the skylight… How to fix, still no clue. baking takes 4ever.

Tried leaving the lights alone and removing athmosphere, skylight, and directional light.
Still getting artifacts post bake.

I’d have to try the scene in .25 but I don’t really feel like importing and setting up the meshes into it since there’s no way to downgrade.

At this point it has to be due to an engine setting that’s less visible when shadows are turned off.
Something like DFAO or similar.

Honestly not getting it. It’s something in the rendering pipeline that’s not agreeing with the specific light or something in my case. Deleting that one light looks much cleaner.

1 Like

ahahaha yeah, there are lights intersecting meshes :sweat_smile: . Many of the lights have to be very close to the walls. I’ll turn them all off, move some away from the geometry, stick one light in the middle, and then I’ll share the project with you.
How would you prefer I send it to you?

In my case literally nothing removed the blotches.

You can replace the corner wall with engine boxes and they still make blotches.

The closest bake to no artifacts was with only the skylight enabled.
Removing the atmosphere made it less evident too.

It may very well have to do with skyAtmosphere.

Haven’t tried to ray trace shadows. So it could potentially also be Cascade doing this.

Eye adaptation makes the blotches more evident. So turning that does get a decent project going, but its still not the quality one would expect…

@Hourences
Any idea / have you ever faced similar bake issues?
Using engine cube with default material?
Should this be submitted as a bug / (not that anyone reads them).

So maybe we’ve found the error then!
Lights can be very close to meshes BUT not partially “digged”/“submerged” in them, they have to be “free floating”!
…maybe you won’t even need to share your project after this test!! …if yes, maybe zip the folder and upload it to google drive?

1 Like

If that’s really the problem, instead of placing random pointlights create BPs of light fixtures with lights to be placed around…

In my case it isn’t. I wish it were that easy :stuck_out_tongue:

1 Like

I’m really grateful for all your help so far!

So, I tried turning off all the lights and adding a couple of point lights to the center of the scene. It seems to eliminate the problem. HOWEVER, if I dim the lights and build again, the problem reappears (less so than before but still there even building at ‘high’).

Then I tried getting rid a bunch of lights, leaving only the important ones I want to test, and moving them away from any meshes. The problem is there again.

It seems that anywhere there isn’t intense and direct light, the artifact shows up.

I’m hesitant to share my project because it takes long time to download and even longer to build the lighting if your were to test anything!

Here is a video showing the problems I’m talking about (download to see higher quality).
https://drive.google.com/file/d/1wDHoKxyus9Il4Xbf9vY9VomOEsdJIskU/view?usp=sharing

Same here.

And eye adaptation basically makes it worse or better depending on the intensity.

I’m busy and it’s pointless for my project, but if you want to test the older engines you may get better results.
Never had issues in .22 for instance.

1 Like

I have been reading the comments since the start of the thread, if it really was not an issue at earlier releases, then a Bug Report is a “must” and also be sure to place the words “regression issue” that those will get the appropriate attention. The report must include the conditions, releases involved and it is “necessary” a sample project or a small video which can show these details enough one which watch could reproduce without the project.