Strange shading on skeletal mesh

I’m having trouble understanding why my skeletal mesh is being shaded this way. after some thorough searching I only found one result with a similar problem, and that thread didn’t really have a solution other than “it might have something to do with the material”

Without seeing your mesh or material it’s difficult to tell. A few things that come to mind:

  1. Did you perform a “Soften Edge” command in Maya (I believe the 3DS Max equivalent is setting all faces to the same smoothing group, not 100% sure)
  2. Do you have an unbaked light in the scene?
  3. Do you use DFAO?

Ah, I did perform a soften edge command, and I’ve noticed it on another model where I did the same thing. Is there not a proper way to do that without getting that result?

Here’s a better picture of what’s happening.

Hi Joolean,

  1. Try to make your mesh completly smooth in your modeling application.
  2. Check in your directional light source the setting ‘Num Dynamic Shadow Cascades’. Set this to a lower value, maybe the artifact disappears.