Strange landscape shadows

Hello everyone,

I got these strange shadows on my landscape. I already tried to increase “Static Lighting LOD” and “Static Lighting Resolution” but I only got more of them. The only way I was able to get rid of them partly was by using Cascaded Shadows Maps but it only worked if I was near them. Any ideas how to get rid of them?

These are my settings: