Download

Stereo Panoramic Player

Hello, I bought SPP recently and it seems like it will be great!

I can get the experience to play fine in editor, but when i build to an Android apk for VR (Pico Neo 2 headset), it doesn’t launch the Pano. I’ve tried editing the level blueprint to play the director at the start, I’ve tried many things.

I don’t see anything in the documentation about “plays in editor, but not in package”. Do you have any tips?

Hi!

We don’t know the “VR (Pico Neo 2 headset)” platform, so we can’t give you specific advices. But usually the first thing to check is if there’re any issues during the packaging/cooking phase. You can check for warnings or errors in the Output Log window.
If no warnings and errors are reported during the packaging phase, you have to check the runtime message logs (https://docs.unrealengine.com/4.26/en-US/SharingAndReleasing/Mobile/Android/AndroidDebugging/).

As a reference, try running our demo application on your device: https://github.com/UNAmedia/ue4-stereo-panoramic-player-demo . It’s compatible with Android and tested also with Cardboard VR.

For further help, we need a copy of the log files generate during a “fresh” packaging and a runtime log retrieved from the device.

Hi everyone! We plan to submit for review the update of “Stereo Panoramic Player” plugin for UE4.27 next week.

Hey there,

if i would want the stage navigation to activate only after a specified time, how could i go about that? The problem im facing is, that the panoramicPlayer is providing exactly what i want, playing a video, then advancing to a selection stage with 2 widgets, and then advancing again. But now i need the selection to be overlayed over the sphere after a certain amount of time.

Only adding a widget to the sphere is not working, obviously, and i have not seen a way to add a StageNavigation to the CurrentStage while it is playing.

Id rather not implement a custom navigation, as i would mostly just copy the functionality of the panoramicPlayer as it is - which seems a bit silly.

greetings, DocHeron

Hi!

There’re several ways to implement what you need. I think the simplest solution is to leverage the standard UMG animation system to control the appearance of your hotspots:

  1. in the widget editor, under the Animations panel create a new animation.

    image

  2. with the animation selected, set the widget “Visibility” property to the value “Collapsed” (this value is important - it makes the widget not visible and not interactive)

    image

  3. then press the “Add keyframe button” (the small icon between the name and value, similar to a diamond with the “+” sign), this will create a new track in the animation with the widget initially collapsed

  4. move the “time marker” at the time you want the widget to be displayed (e.g. if the panoramic video lasts 120 seconds, move it to 110 - or after the amount of time you want in case of panoramic images).

  5. set the widget “Visibility” property to the value “Visible” and press again the “Add keyframe button” to store the change of value (this makes the widget visible and interactive).

  6. now move to the Graph editor and add an “Event On Initialized” node and configure it as below (you’ll find the animation object in the Blueprint variables - it corresponds to the animation you created before):

    image

  7. Done :slight_smile: (you can play further with the animations if you want also fade effects, etc)

  8. Remember to use this new Widget as marker in your Panoramic Stage.

1 Like

Hi. Did you manage to solve this problem?

Hello,
Is it possible to create several collision trigger spheres that would similarly like in the demo ( UNAmedia/ue4-stereo-panoramic-player-demo) play 360 video after interaction?

I would like to create 5 small spheres which would after interaction with a hand (mesh) enter 360 experience depending on which of these spheres have my hand (mesh) interacted with. Each sphere should have only 1 video inside and then go back to the main menu (level).

Yet I was not able to do it other than playing them in batch though the media player and panoramic experience.

Thank you for you response.

Hi!

You can achieve what you want using distinct Panoramic Experiences:

  • create a distinct Panoramic Experience and Panoramic Stage for each “360 experience” you want to show to the user;
  • add a Panoramic Director actor in scene, leaving its Experience property set to None;
  • place your trigger volumes to detect the needed user interactions;
  • when you detect the wanted interaction, call the method Play() on the Panoramic Director actor, passing as argument the Panoramic Experience that you want to show to the user.

The same exact setup (for a single Panoramic Experience only) is shown in this video tutorial at 7:00:

Hi UNAmedia team,

We are attempting to package a simple UE project that incorporates the Pano Player and a streaming media source to be tested in a multiplayer playback environment.

While the project packages and runs well for Win64, we receive an error every time we try to package to Linux:

UATHelper: Packaging (Linux): ERROR: Missing precompiled manifest for ‘StereoPanoramicPlayer’. This module was most likely not flagged for being included in a precompiled build - set ‘PrecompileForTargets = PrecompileTargetsType.Any;’ in StereoPanoramicPlayer.build.cs to override.

Do you have any experience with this error and how we can resolve it? Does it have something to do with manually including the plugin within the compiled project?

We already tried inserting that command into the Build.cs file, as well as placing the plugin into the project folder as suggested by some solutions to the generic error.

Please let us know if you need more info from us. Thank you!

Hi again,

There was a solution on a forum for another plugin that suggested replacing “Runtime” with “Editor” in this line of the .uplugin file:

	"Modules": [
		{
			"Name": "StereoPanoramicPlayer",
			"Type": "Runtime",
			"LoadingPhase": "Default"
		}

This actually worked to package Linux successfully, but I am not sure if the final works properly yet, nor if this is the best method or if it ended up bricking something else.

Just wanted to update you, but please let us know if there’s a more proper fix for this issue.

Thank you!

Hi,

unfortunately we have limited experience of running the plugin on Linux, but the plugin code is quite “normal” and it relies on the ordinary APIs provided by UE4, so it should compile without major issues. BTW the plugin compiles and run on many platforms, included Android that runs a Linux kernel.
The reported problem seems an issue of UBT, before starting the compiling phase.

The “workaround” you mentioned is wrong: setting the plugin Type to Editor means that the plugin will work only inside the editor and will not be available at Runtime (i.e. it will not build with your application). It sounds very strange that it works for you, but if it works… :slight_smile:

Accordingly to the message you reported in the first comment, it seems that the UE Marketplace is not providing pre-compiled versions of the plugins for Linux. If this is true, the only option you have is to manually embed the plugin into your source project. Can you verify if the UE Marketplace created a binary version for your Linux OS?

You can embed a plugin from the UE Marketplace copying the plugin source code downloaded from the UE Marketplace and saving it under <PROJECT>/Plugins/ (as a reference for Stereo Panoramic Player, you must end with the file StereoPanoramicPlayer.uplugin at <PROJECT>/Plugins/StereoPanoramicPlayer/StereoPanoramicPlayer.uplugin).
I don’t know how the Launcher work on Linux and where it saves the file, but under Windows you will find the source code of installe plugins under <UE_ROOT>\Engine\Plugins\Marketplace\.

Dear UNAmedia,

thanks for the reply earlier, it helped a lot. Now to my next question:

in our Project, we have a sound related problem. In Unreal, i muted the soundComponent of the PanoramicDirector via Blueprint and start playing some Sounds via “PlayAtLocation”. When launching the project on quest, the mute doesnt work anymore, and “my” sounds dont play.

It seems to me, that the sound playback is handled differently when on the quest. The video sound playing is not a big problem, as we can just remove the sound of the video. But how would i go about playing audioFiles on the quest?

Greetings, DocHeron

Hi, I’m sorry but we can provide support only for issues and questions strictly related to our plugin, not for generic questions about UE4 or their supported platforms. For issues with UE4 or its supported platform, please contact Epic of try on other dedicated forum threadsr

The only thing that the plugin does with the MediaSoundComponent, is to connect it to the MediaPlayer if one is provided (calling the method SetMediaPlayer). This happen in the BeginPlay of the Panoramic Director. I’m not sure of the implications of this “connection”, but you could try to mute the component soon before activating the Panoramic Director.

Anyway, from your description, as your changes were apparently ignored, I would double check that your changes were correctly packaged on the Quest. From our knowledge, audio is not managed differently on the Quest.

1 Like

Hi! The version of “Stereo Panoramic Player ” for UE4.27 is now available in the UE Marketplace. If needed, restart the Epic Games Launcher to download it.

Can you tell me if your plug in supports H.265 Video? It is only 12 seconds. When I bring it in, it does not show a picture, and when I try and connect it to the stage it will not come up in the drop down menu, and when I drag the movie into the box it is red instead of green. It is the same size as the previous images, and all are formatted as Stereoscopic over under 4096x4096.

Hi!

It seems you’re not using it in the proper way: the Panoramic Media Source drop down menu (in the Panoramic Stage options) lists all the available UE4 media sources in your project. If your video is not listed, then your project setup is wrong.

The plugin is never involved in the decoding of the video stream. The video decoding is exclusively performed by the standard UE4 Media Framework: the UE4 Media Player decodes the video stream into a UE4 Media Texture, that is continuously updated by the engine. The plugin then displays the available content of the Media Texture in the Panoramic Sphere.

Before using a video with the plugin, you must ensure to have the Unreal Engine media playback system correctly set-up and working on your device with the needed videos. When you have working Media Player, Media Texture and Media Source assets, then you can use them to configure the plugin.

Here you can find a detailed How-To by Epic on how to use the Media Framework to playback a video file on a 3D plane: https://docs.unrealengine.com/en-us/Engine/MediaFramework/HowTo/FileMediaSource. Ensure to have a working version of this how-to running on your device before moving to our plugin.

As the plugin doesn’t decode any video stream, but relies on the standard UE4 Media Framework, you must look to Unreal Engine documentation for the supported formats/encoders/resolutions on you platform. Here is a starting point: https://docs.unrealengine.com/en-US/Engine/MediaFramework/TechReference. Any format that Unreal Engine is able to decode can be used with the plugin.

I have read through all that documentation, and made sure my videos have all 3 of the Media Player, Media Source, Media Texture, and even a plain Texture. They are all linked properly AND the video is showing up on the icons for Media Texture and Texture, and my videos still do not show up in my Panoramic stage drop down. So what is the reason it does not work now? Seems like it should be working now if your plug in does what it says it can do…

I suspect that the reason is simply a wrong setup of your project.

To show you how simple it is to use our plugin to play a 360 video, here is a quick recording of a complete setup from scratch of a blank Unreal Engine project with the plugin enabled. The complete configuration requires less than 90 seconds.

We can provide support only for questions strictly related to the plugin and its API. For generic help with Unreal Engine, please rely on Epic resources or the community.


I have followed those exact steps dozens of times, and it doesn’t allow me to see the Stereoscopic 360 video in the stage drop down, and this error sure appears to be connected to your plug-in.

You now have a video showing you everything. I really don’t know how to help you further.

Errors are reported in red and are not related to our plugin.

EDIT: the best thing is if you ask for a refund. Please follow the instructions here: https://marketplacehelp.epicgames.com/s/article/How-do-I-request-a-refund-for-a-Marketplace-product-I-ve-purchased