Steam Audio

Hey folks,

Feel free to post any Steam Audio related questions or experiments you do here, so we can keep things consolidated and make it easier for people to get help.

Be sure to grab the user manual if you’re just getting started - it should be pretty helpful.

We track known issues over at our GitHub issues page.

We have a forum over at our Steam community that you’re welcome to explore - you may find useful discussions there as well.


Are you going to fix steam voice chat getting busted by server travel?


Just downloaded the 4.16.0 Preview 2 download for UE4 on IOS, want to play and have a look at the new UE4 Audio Engine and Steam Audio plugin.

Got the manual open, first thing it says to do is to Enable the Audio Mixer Functionality.

  • Says to click the down arrow next to the 4.16.0 Engine and click on 'Create Shortcut".
  • When I click on the arrow all it show is Options, Set Current, Remove and Verify.

Is there another way to create a shortcut to the Editor?


Hey Rodnino,

As of 4.16, we will only be supporting Windows. Generally, your goal is to pass the -audiomixer flag to the UE4 executable. I think this may be helpful to you:

Voice chat is separate from Steam Audio.

Is there a way to control the occlusion attenuation amount (with it enabled I mean)? Seems like right now occluders just 100% cancel out the direct sound regardless of any phonon material or sound attenuation settings, even if they’re very thin. The built in occlusion system doesn’t seem to work with steam audio enabled so the “Occlusion Volume Attenuation” slider doesn’t do anything. I’m pretty sure some of the Impulsonic videos demonstrate diffraction and partial transmission so what happened to that?

Also, the model doesn’t seem to update when moveable actors are moved, at least the occlusion, even with everything set to Real-Time. Is this a bug or a limitation of the system?

Currently, we do not support transmission (sound passing through geometry) - we offer Partial occlusion, which will smoothly interpolate direct sound down to 0 volume as the source passes out of view.

We only support static geometry at the moment. We do, however, have the ability to hook into a custom raytracer, so I plan to experiment with using the UE4 raytracer and see if we can get dynamic geometry without having to implement complex data structures in our backend.


I noticed that you are already using ambisonics as part of your engine. Is it possible to play B-Format files with head tracked rotation and decoding to binaural?



Thanks for the information, I find it hard to believe that use will be only supporting Windows, could you clarify more please? I’ve downloaded the 4.16.0 Preview 3, the plugins are there and enabled, just can’t enable the Audio Mixer Functionality. Can you tell me whether this will work on a Mac and if not what is the point of being able to add it to the library in the Epic Games Launcher. The UE4 Roadmap on Trello under Done and Ships with 4.16 says in the New Audio Engine Card that Mac is one of the platforms targeted for ‘Early Access’ Release.

It seems there may be some confusion. The Steam Audio plugin will only support Win64 for 4.16. The new audio mixer is a separate thing - this question probably belongs in New Audio Engine: Quick-Start Guide - Audio - Unreal Engine Forums or its own thread.

Thanks yeah there has been some confusion. Great thanks for clarifying, I am working out of office on a project using Win64 for 4.16 and just wanted to play with steam audio and the new audio engine on my iMac. Thanks for your help.

I can’t get environment audio effects to work. Have done everything in the manual: put geomtry and material on static meshes, added phonon volume, generated probes, added phonon source to the actor with audio source, set reverb source settings to Baked (in project settings too), built everything.

Spatialization and occlusion works but the environment audio doesn’t, what am I doing wrong?

EDIT: figured it out, it was just too quiet.

When trying to package for Win64 with Steam Audio enabled on Win64 I get this error message.

*UATHelper: Packaging (Windows (64-bit)): UnrealBuildTool: Creating library E:\Unreal Projects\xxx\Binaries\Win64\xxx.lib and object E:\Unreal Projects\xxx\Binaries\Win64\xxx.exp
UATHelper: Packaging (Windows (64-bit)): UnrealBuildTool: UE4-SteamAudio.lib(Module.SteamAudio.cpp.obj) : error LNK2019: unresolved external symbol “unsigned int __cdecl SteamAudio::GetNumTrianglesForStaticMesh(class AStaticMeshActor *)” (?GetNumTrianglesForStaticMesh@SteamAudio@@YAIPEAVAStaticMeshActor@@@Z) referenced in function “private: void __cdecl UPho
nonGeometryComponent::UpdateStatistics(void)” (?UpdateStatistics@UPhononGeometryComponent@@AEAAXXZ)
UATHelper: Packaging (Windows (64-bit)): UnrealBuildTool: UE4-SteamAudio.lib(Module.SteamAudio.cpp.obj) : error LNK2019: unresolved external symbol "unsigned int __cdecl SteamAudio::GetNumTrianglesAtRoot(class AActor )" (?GetNumTrianglesAtRoot@SteamAudio@@YAIPEAVAActor@@@Z) referenced in function “private: void __cdecl UPhononGeometryComponent::UpdateStatis
tics(void)” (?UpdateStatistics@UPhononGeometryComponent@@AEAAXXZ)
UATHelper: Packaging (Windows (64-bit)): UnrealBuildTool: E:\Unreal Projects\xxx\Binaries\Win64\xxx.exe : fatal error LNK1120: 2 unresolved externals

Anybody else experiencing the same problem? Any workaround available?

I opened a bug report for the issue here:

Hey xN31,

I’m aware of the issue and have a fix for it coming out in 4.17. There are a few functions that were incorrectly #ifdef’d to compile only with the editor. The only workaround currently is to compile the engine from GitHub and apply the patch.

Ok, thanks. Too late for including the fix in 4.16 final? :wink: Where can I find the patch if I want to compile the engine from code? Is there already a pull request?

@freeman_valve: When exporting the scene the first time (after applying phonon geometries and materials) a file [level_name].obj gets created in the Contents folder and I get asked “A change to a source content file has been detected. Would you like to import it?”

Shall I import or ignore it?

In my tests the volume does not drop to 0 when the source is fully occluded, even if no reverb is configured. Is there something wrong in my setup or am I hearing some sort of sound indirectly reflected by the objects around?

You can just ignore it. The obj is useful for verifying scene geometry is what you expect.

Hmm - can you post a video with the exact settings? Are you using partial occlusion or raycast?

Occlusion and indirect sound

So, using raycast. Did some more testing:

  • Object A is a blueprint with a static mesh which plays a sound each time the object collides with something. I’ve tried using “Play sound at Location”, “Spawn Sound at Location” and “Spawn Sound Attached”, setting in any case the same attenuation (which includes steam occlusions). Occlusions do not seem to work properly (I hear the object hitting even when behind other objects)
  • Object B is a similar blueprint, but with also an audio component attached with a looping sound (same attenuation). Looping sound works fine with occlusions, bump sounds no (e.g. throw the object, stop hearing the looping sound and then hear the bump)

Any idea why?

Also, when the looping sound is occluded, it gets completely muted even if I enable indirect sounds (e.g. add a real time reverb). Is this something expected?