Static mesh level shadows not building correctly

I have built my level in blender 2.73. It is made up of individual cubes, which when imported into ue4 are changed into a single mesh. When I import and drag the fbx file into the editor, the preview shadows show accurate shadows, just low quality (Img 1). After I try to build the map, there are no errors, however the shadows completely disappear except for a few other meshes (all movable, Img 2 &3). If I set the level mesh to movable then dynamic shadows make it work, but the level is not moving, so I would like to have the best performance.

Album of screenshots: ue4 help - Album on Imgur

.fbx download: OpeningScene.fbx

I did that, but the shadow issue is still there. The only thing that changed was the fact that now I have a bunch of meshes instead of just one.

Also I’ll point out that if I switch the light from stationary to static the whole level becomes black, except for the little catwalk thing.

If they come all in as one object they will share the same lightmap which will have really poor resolution. The solution is when you import the .FBX, look for “Combine Meshes” checkbox and UN-check it. Now they will all come in as separate pieces. Don’t worry they will all have the same pivot point, so if you select them all and drag them into your map they will be laid out as you had them in Blender.

You need to change the lightmap size of each individual mesh. (open the mesh browser and look for lightmap resolution).
Use multiples of two for those values.
Most often 16,32,64,128,256 and 512 will suffice unless a mesh is really big then ou can consider 1024, 2048.
Higher is not currently possible unless you change some .ini settings.

checks out .fbx

I notice you dont have seperate lightmaps for the meshes?
Its very hard to guess whats wrong without really looking at the project.

If you have skype, add me (Luos_83) so we can take a look at it and hopefully figure out whats wrong :slight_smile:

Overriding the light map size to 1024 didn’t change anything. There’s a shadow there, but they are only from dynamic objects. The static level piece isn’t casting and shadows onto the other static map pieces. Is it something to do with the ceiling holes? They should work, but if I’m doing something wrong then please tell me. I tried adding a normal BSP to the map to create shadows, but it was glitching out with shadows. Could it be the material causing this issue?

I figured it out the issue was the meshes were not uv unwrapped. Unwrapped them in blender and it works now!