Static Mesh Export - UVW Corruption

I have some content that I migrated from the Mothership Marketplace content, it currently looks like this:

I then try and export it, cut it in half and reimport it so i can use it in a 2.5D setting.

It has worked for segments B and C, however with A (This one) when I reimport it the UVW’s are completely broken, so just to prove it wasn’t my bad 3D skills, I exported the model then reimported it without any changes, and this happens:

Theses are the results the engine provides just from Exporting and Reimporting a mesh that was in the engine.
What is happening and why would this happen to only this segment, could it be something to do with the way it was built originally?

P.S. I tried a lot of things to fix this, i scanned all the UV channels found similar ones, MOVED them to Channel 0 reimported and it still looks like this.

Please help,

the uvw is fine, but it looks like for some reason the lightmap uv is used on the first uv-map instead of 2nd.

Thats odd.

Well the UVW is still gone entirely on reimport, and it completely ruins the texture and i think it also removed a material element.

on a side note, its now also done this to my icons.

It might be hard to tell but the Door Asset is in every thumbnail, even though it doesn’t exist in ANY of the Blueprints.

You can fix the above issue by deleting/removing your Saved and Intermediate folder, it is probably only the saved folder but I just had the engine rebuild both to guarantee

**EDIT: It returned again shortly after…

Hi Nemecys,

I’ve submitted UE-29582 for this issue. It looks like some material elements are being combined on export which is causing the issue. I was able to reproduce this with some other sample assets from other projects like Sun Temple for example. I exported the SM_Window and it combined element 0 and 2 into a single element which played havok with the UVs for the material assignments.

Thank you for reporting.