Static Mesh Doesn't Update After Reimport

I’m receiving “reimport successful” messages, however static meshes aren’t updating to reflect new changes. I can manually import the mesh again and overwrite the previous asset the and changes are reflected. This is not an issue with a single mesh, none of the meshes in the scene are reimporting properly.

Hi Dobblin -

Can you be more precise as to how you are reimporting the meshes versus manually reimporting them? Do you mean using the automatic reimport folder feature versus right clicking in the Content Browser to reimport?

Thank You -

Eric Ketchum


Clicking “reimport” in both the content browser and the static mesh editor fails to update any changes. I haven’t had anything update automatically, so I’m going to assume I’m not using an automatic reimport folder. Pretty new to UE4 so apologies in advance for being vague.

For what I know, the fbx file is first exported in a .fbm folder and then imported in unreal engine. The ‘reimport’ function looks in the .fbm folder rather than opening again the fbx file. That is why the reimport doesn’t work like expected.

fbm folders are only generated when you have embedded Material and Texture Media and you are importing those items into the engine. If you are only importing a model then no FBM folder will be generated.

Hey -

Can you give me a complete list of your steps to updating a mesh? You have done an initial import of a mesh, then you open your modeling program make changes and re-export and overwrite the original FBX that you used to import, or are you making a new FBX each time you make changes? If there is a step there that I ma missing that you are doing please let me know -

Thank You

Eric Ketchum


Yes, I am making changes to the same FBX file. I’m saving FBX from Modo to a directory, importing the mesh via “Import” in content browser, making changes later to the exact same file in my 3d package and saving. I’m right clicking on the mesh in the content browser, selecting “reimport”, and receiving the confirmation message "Successfully Imported: “Meshname” Static Mesh from file “Meshname.fbx”.

To be sure this wasn’t an issue with Modo’s changes not saving properly while the mesh is was open in the 3d program I tried saving, closing Modo, and then reopening the FBX in Modo to confirm the changes before reimporting the mesh in UE. Reimport still failed to reflect the changes.

I ran a few tests. This issue persisted in two other projects I have, both in versions 4.6 and 4.7. However, when I saved a mesh to my desktop on my C: drive, the mesh would reimport properly and update changes. I have UE4 installed on my secondary E: drive as well as all of my project folders containing textures and FBX meshes.

I am only having this issue with static meshes, any updates to textures are reflected just fine after reimporting.

To confirm this was an issue with my entire E: drive and not just the directory I usually store my meshes, I also saved to a different location on E: and the reimports still failed.

Hope that helps, thanks for your time.

Hi -

Thank you for the additional information. It helped to narrow down the possible issues. Can you check one of the meshes that is not reimporting correctly and let me know what the Import Settings >> Source File Path is listed as (located in the Static Mesh Editor)?


Hi Eric, this is copied from source file path in the editor: “…/…/…/…/…/…/…/Projects/June 14 Noob Challenge/Meshes/Bookcase02.fbx”

This is the actual path as copied from the “open source location”: E:\Projects\June 14 Noob Challenge\Meshes


Hi Dobblin -

Try to set the actual path in the Source File Path of your Static Mesh Editor to see if the reimport will correctly work for you. Also if you haven’t tested yet, try to update to 4.8 and see if the issue resolves itself.

Thank You

Eric Ketchum

Hello, i’m having the same issue. When i import the mesh through drag and drop it works fine, and as soon as i right click and reimport, it looses some parts.
The mesh is made that way (if that can help resolve the problem)
-Made of several sub objects
-Made of several collision boxes (but i read recently in the do that only one is supported)

So having read that last detail, i re exported the mesh selecting only one collision box, but the problem still occure.
I also checked that the path is the right one…
I deleted the backup versions of it just in case, but still…

Hi Darknoodles -

This is an issue we are actively investigating. Currently I have no new information to provide, but I have added your information to our bug reports and will keep you informed as our investigation continues.

Thank You

Eric Ketchum

I never had this issue before, but just started a new project got this exact issue. I investigated the difference on my previous project and have concluded that it has to do with the file path name. On my latest project with the issue, i tried to use a local Dropbox folder. I changed this to a non-dropbox path and it now works again to re-import as normal. So it either doesnt like dropbox paths, or it could be related to the length of the file path.

I’m not sure if this will help, but I ran into the same issue and I can give you an idea on what I was able to replicate.

My folder structure was
/BlenderContent for my WIP meshes
/LifeSupport where I created the project

I was exporting the fbx files from Blender into the BlenderContent directory where I was saving the .blend files and related assets. When I imported into UE4 (version 4.9), the import directory was

…/…/…/…/…/…/Dev/hab/Blender Content/StaticMeshes/airlock_test.fbx

And while the “reimport” function seemed to be doing something, nothing would update on the mesh.

From the directory C:\Dev\hab\LifeSupport\Content\FirstPersonBP (where the airlock.uasset file was placed) that path would walk back to the C:\ root, but either way it doesn’t seem to be finding the file for reimport.

Then I tried moving the fbx file into the C:\Dev\hab\LifeSupport\Blender folder so it would be within the project directory structure. When exporting or copying an altered fbx file into that directory, the reimport works fine. The import path was listed as


Just to make sure it wasn’t because of the space in the “Blender Content” dir name, I created a new folder at C:\dev\hab\test to export to. The import path format was similar (…/…/…/…/…/…/Dev/hab/Test/airlock_test.fbx) and the reimport didn’t work.

Long Story, Short: The reimport function didn’t work when the fbx file I was importing was outside the project root directory, but worked as expected when it was inside the project directory.

Hope this helps.

i have the same issue as everyone else here, just updated to 4.10.4 and started a new project and reimported an FBX mesh with changes. says it was successful and the model does not update. my models currently don’t have any texture on them. there is obviously a probelm with the assets not updating to reflect the changes or checking for changes when exported from any 3d program.

Hello PaulWorster -

How exactly are your reimporting the FBX file?

Eric Ketchum

I have just started a new project (with 4.10) and also have this problem with re-import of static mesh not working. Our older projects work fine, but were started with older versions of the engine that were continually updated; all the way back from the Rocket closed Beta. It seems that this issue only occurs on newly created projects.

To be clear: import a static mesh from FBX, make a change in 3DSMAX, and re-export the mesh with changes over the top of the same FBX file. Right click on the mesh in the Content Browser and choose Reimport. I get the successful message, but the mesh does not update.

I have both the Art Source and Unreal Project saved on D: drive. This particular project has the Artsource in D:/Perforce and the Project lives in D:/unreal Engine , where as our other projects have both the Art Source and the Project rooted in D:/Perforce . Maybe having them both he project and the FBX source in the same folder structure is why the older projects work?

This appears to have already been reported with UE-11538 and is marked as “To Do” but with no fix version as of yet. Look for this to be resolved in a future release of the engine.

Also getting this issue in 4.11. Reimport says it’s successful but does nothing. Only dragging and dropping the file on top of the current one and clicking ‘yes’ to overwrite actually works, but then you have to re-assign materials and set the mesh asset up all over again each time.

same here, also this problem with fbx reimport missing part of the mesh, even when the fbx (opened in maya) is complete