Static mesh can't be duplicated with Alt+drag

Hi everyone!
I have a problem with duplicating my static meshes in 4.7.5. Now everytime i try and duplicate a static mesh it just duplicates an empty actor that apparently is just Null.

Heres a picture of the message i get when i try to build my lighting:

The duplicating still works with my old assets that i have imported and the problem seems to occur only with the latest assets. The problem occurs only in one of my projects so maybe ive accidentally changed some setting or something. Any ideas? Thanks for all help.


I have tested static mesh duplication with alt+drag in 4.7.6 and there are no errors with this command. I would suggest updating your version of UE4 to 4.7.6 for better results with alt+drag.


Thank you so much for answering! I didnt even realise there was a new version so that probably does it.

You’re very welcome. Please let us know if we can be of any additional assistance. :slight_smile:

At first i thought this solved my problem but it seems it actually didn’t. Again i tried importing to another project and it worked fine but it doesn’t work for this one project(4.7.6) with the same exact import and export settings. Here are the settings for the working one:

And here are the settings for the problematic one:

Any ideas? Thanks!


Are you trying to import the exact same mesh into two different projects? Or are you switching up what you’re trying to import?

Looking forward to hearing back from you, thanks!

Yea it’s the same asset with the same export settings from blender. Could there be something i could have clicked accidentally in the project’s settings or something?


Would it be possible for you to upload this asset that’s causing trouble for you? If you do not want it to be released to the public, you can zip the asset, upload it to Drive and actually provide me the link in a private message on the forums.

Looking forward to hearing back from you, thanks! :slight_smile:

The problem occurs with any asset but here’s an fbx file that I was able to reproduce the problem with:
And here’s the blend file:
I hope this helps!


Thank you for providing me the fbx you’re having trouble with. In the newest version of the engine that’s been released (4.8.0 Preview 3) I have not been able to reproduce this issue. Unfortunately, I am not able to roll back to 4.7.5. Do you have 4.8 Preview 3 installed? If so, are you able to reproduce the same issue on that version of the engine as well?

Looking forward to hearing back from you, thanks! :slight_smile:

Nope, it still doesn’t work. I also tried updating blender but that didn’t change anything. Importing still works for other projects. Also it seems that .obj files don’t work either in this particular project but they do work in other projects.


Could you make a duplicate copy of the project you’re having trouble with, and then delete the saved, intermediate and config folders out of the projects folder (in Windows Explorer). Once you’ve done that, load up that project and try to import another .fbx and let me know how it responds. Make sure you do this on the duplicate.

Looking forward to hearing back from you, thanks!!

I still didn’t manage to get it work. I also tried opening an older version of the project and the same .fbx works just fine, however I don’t really want to revert back to it since it is quite an old iteration, so a solution would be a better option. Also ( I don’t know if this is important) I noticed that when I select the duplicated actor and try to set the static mesh in the details panel it only allows me to set an old asset that was imported before I noticed this problem. Also it seems that I can export older assets (again, made before the problem) to the project and duplicate them succesfully but new blender assets don’t work, but i’d say that the problem is not in blender since I still can import newer assets to other projects. Hope this helps!

I had very similar problem. I solved it by using directory names which do not contain special characters (in my case it was ‘[’ character).

Hope this helps.

That unfortunately is not the problem in my case, the names are quite straight forward. But thanks anyway!


I have not been able to reproduce this, neither has any of my colleagues. Is there absolutely anything that you’re doing besides going through the following steps: Import > Open .fbx > Import All? Please note that I’ve also tried migrating the fbx to another project as well and I have not experienced the same issue either. Another thing that I have tried without experiencing the issue you’re reporting is importing the fbx object in a 4.7.6 project and converting it over to a 4.8.0 preview 3 project. The fbx has responded correctly with all of the attempts I’ve made.

I feel that this is specifically related to that one project that you’re working within. Have you been able to reproduce this in any other project since we last spoke?

Looking forward to hearing back from you, thank you! :slight_smile:

Thanks for taking the time to test this. I’ve experienced this issue only in this one project and haven’t been able to reproduce it in any other project. Just to make sure im not doing anything wrong in the export process itself, here are the settings for that:

Can you spot anything suspicious? I also tried using FBX 6.1 ASCII but again without any progress.

Hey Elias,

You should switch your -Z forward Y up to -Y forward Z Up. Also, please remove “Add bones”, and if you have not yet scaled your mesh already, you’ll want to make sure you do so otherwise, it’ll be imported as a very small size. Also, if you have any bones, you’ll need to have armature selected if you’d like those to come in too. Other than that, everything looks good from the screen you provided.

I hope this helps, have a great day! :slight_smile:

Thank you for taking the time to help me with this. But I guess I’ll just have to start building back up from the older version. Thanks though!