Starnge Shadows | Please Help (Bug )

I don’t know if the section is right I think this question is maybe for “Bug Reports Section”.
Anyway, I just start to learn Unreal Engine 4 and I am a beginner in this domain. The tutorial shows me how to create a level. That tutorials (at least) have photos, but I can reach that product from the photo, like I have a bug I think with the shadows when I built the light the shadows became strange and wouldn’t have to be so.

Please if you can help me I will apreciate very much! Thanks in advance!
And sorry for my bad english!

Try augmenting the resolution of the floor’s lightmap. To do that just select the floor and on the details panel look for an option that says override lightmap resolution, it will probably be unchecked, so check the box first and then change the number to something like 512. I think that will help.

I just found a guide that troubleshooting the lighting. I have to change the “Cascade Shadows Map” options at Directional Light and will work. But I don’t get it, Who want that shadows and when build can not stay like the real shadows, I mean why thouse settings can not be set by default by UE4 Developers?

Because the engine is heavily oriented towards optimization (Like every game engine should). Yes Unreal can deliver amazing graphics, but the user base of UE4 is very diverse now and not every device has the capacity to handle that work, so they don’t leave the Ultra Mouth Dropping graphics options as default. You have to choose what works best for you.