Download

Speedtree lighting question

Hi guys. So I’ve put a few speedtree trees in my level, which looked alright, and I decided to build lighting overnight. The lighting was built, and the trees got a lot darker in their interior. It doesn’t seem like they received any bounce lighting. I’m doing this in a slightly modified Advanced_Lighting scene.

It was also complaining about overlapping lightmap UVs, but this came straight from Speedtree…? Any ideas?

1.jpg

This is what the lighting view shows. Leaves should be letting more light transmit through them. Is there a way to pull that off in the shader somehow? Some sort of “Light blockage” setting I can adjust?

Also, everything is placed with mesh scattering. The smaller bits of foliage aren’t receiving any light, but the trees are… I’m not sure why.

I haven’t experienced this exact problem but UE4 doesn’t seem to like it when you import the LODs with billboards. Did you import them both into the engine?

I believe I hit both, but it’s only using the 3D lods.

Sorry, it was only imported with 3D lods. That’s the default setting.