Source Lightmap Index

I have about 8 thousands assets going crazy with invalid lightmap settings caused by the “source lightmap index” being set to 1 instead of 0. I tried to edit this setting through the property matrix, but no luck, can’t find it…
As editing each 8092 assets one by one seems quite unreasonnable, I’m starting to feel quite desperate and looking for any kind of idea… Thanks in advance…

EDIT : UE was just being mega slow with the whole scene loaded…

The default setting will try to copy your last UV channel to a new channel and use the existing seams to flatten it out and pack to a lightmap UV which it will then automatically assign as the lightmap UV channel.
If you turn that option off on import, then it will use the last UV channel for your lightmap UV’s, which is the preferred workflow where the second UV channel is what you use for lightmaps and the first is for your material.
If you change something and result in fewer UV channels, then you would be required to go through and reassign the lightmap UV channel.

Thx, will keep that in mind :slight_smile:
(and problem solved the moment I called for help, as always…)