Some parts of foliage are 100% dark

I had a warning with overlapping UVs on a foliage mesh and so I fixed the overlapping UVs so the warning doesn’t come after building but the mesh has still parts which are 100% dark. I have a skylight there.

What can I do?
Did I something wrong?
Or is this an other issue as overlapping UV?

Please help me, my map is ready only stuck on this problem

(You can right click on the pictures for better zoom)

https://picload.org/image/rardrplo/zwischenablage00.jpg

https://picload.org/image/rardrplc/zwischenablage01.jpg

https://picload.org/image/rardrplp/zwischenablage02.jpg

https://picload.org/image/rardrpcg/zwischenablage03.jpg

https://picload.org/image/rarddllw/zwischenablage04.jpg

Make sure that actual lightmap resolution is sufficient.

I tried lightmap resolution 64, same dark parts. 128 or higher didn’t work, I got then the error message after building, so i went back to 64:

“Warning InstancedFoliageActor_0 The total lightmap size for this InstancedStaticMeshComponent is large, consider reducing the component’s lightmap resolution or number of mesh instances in this component”

-Can it be something wrong with the normals?
-Did I used the correct lightmap channel? (It confuses me that the uv overlapping channels is 0 and the correct channel 1)

I found the solution, after setting by material the shader model to “Two sided foliage” and connect the texture with subsurface the dark parts are gone.

Hello wARmAcH1n3,

I had this same problem when doing my tropical island using Stationary Lighting, I had to set my foliage to moveable in order for it to go away. I eventually just went Dynamic Lighting because of so many issues. Maybe it will help you.